summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2017-09-25 17:05:57 +0200
committerDavid Vogt2017-09-25 17:05:57 +0200
commitcab728c4071af28eb232867ece2e24cbe8c10242 (patch)
tree59f852ce41c73b0458df92416d78d258860c6f4f
parentbbd9466218ae83a18d9be1a9906db01ef4b1237b (diff)
downloadaur-cab728c4071af28eb232867ece2e24cbe8c10242.tar.gz
Version bump to 1.0
Also, move from PyPI to github for the source, and patch out a overly specific version requirement for the texttables python package.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63308ea78161..043538328493 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fahrplan
pkgdesc = A SBB/CFF/FFS (Swiss railway) commandline based timetable client
- pkgver = 0.2.3
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/dbrgn/fahrplan
arch = any
@@ -10,8 +10,9 @@ pkgbase = fahrplan
depends = python-six
depends = python-dateutil
depends = python-requests
- source = https://pypi.python.org/packages/source/f/fahrplan/fahrplan-0.2.3.tar.gz
- md5sums = 6121f1d2fc16d4b9472ddacdef3f8421
+ depends = python-texttable
+ source = https://github.com/dbrgn/fahrplan/archive/v1.0.0.tar.gz
+ sha256sums = f87f842784c305a363a15265f220803fd306b11fd3ab476fe4f233a9ce3092a6
pkgname = fahrplan
diff --git a/PKGBUILD b/PKGBUILD
index b57addb9cb8a..1fc2ff9b005d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,25 @@
# This PKGBUILD is maintained at https://github.com/winged/aur-packages
pkgname=fahrplan
-pkgver=0.2.3
+pkgver=1.0.0
pkgrel=1
pkgdesc="A SBB/CFF/FFS (Swiss railway) commandline based timetable client"
url="https://github.com/dbrgn/fahrplan"
-depends=('python' 'python-six' 'python-dateutil' 'python-requests')
-makedepends=('python3' )
+depends=(
+ 'python'
+ 'python-six'
+ 'python-dateutil'
+ 'python-requests'
+ 'python-texttable>0.8.6'
+)
+
+# texttable<0.9,>=0.8.6
+
+makedepends=('python3')
license=('GPLv3')
arch=('any')
-source=('https://pypi.python.org/packages/source/f/fahrplan/fahrplan-0.2.3.tar.gz')
-md5sums=('6121f1d2fc16d4b9472ddacdef3f8421')
+source=("https://github.com/dbrgn/fahrplan/archive/v$pkgver.tar.gz")
+sha256sums=('f87f842784c305a363a15265f220803fd306b11fd3ab476fe4f233a9ce3092a6')
if [ -n "$VIRTUAL_ENV" ]; then
echo "Warning: You're building within a virtualenv. Use"
@@ -21,11 +30,12 @@ fi
build() {
- cd $srcdir/fahrplan-0.2.3
+ cd $srcdir/fahrplan-$pkgver
python setup.py build
}
package() {
- cd $srcdir/fahrplan-0.2.3
- python setup.py install --root="$pkgdir" --optimize=1
+ cd $srcdir/fahrplan-$pkgver
+ sed -i -e 's/texttable.*/texttable>=0.9/' requirements.txt
+ python setup.py install --root="$pkgdir" --optimize=1
}