summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2015-08-04 09:31:52 +0200
committerDavid Vogt2015-08-04 09:31:52 +0200
commitec581e6c9f6880b269e18e4b93f0d44a5ee55732 (patch)
treebf0f7a14618f01917a476816d549da74da8b9a9d
downloadaur-ec581e6c9f6880b269e18e4b93f0d44a5ee55732.tar.gz
initial: fahrplan
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63308ea78161
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fahrplan
+ pkgdesc = A SBB/CFF/FFS (Swiss railway) commandline based timetable client
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/dbrgn/fahrplan
+ arch = any
+ license = GPLv3
+ makedepends = python3
+ depends = python
+ depends = python-six
+ depends = python-dateutil
+ depends = python-requests
+ source = https://pypi.python.org/packages/source/f/fahrplan/fahrplan-0.2.3.tar.gz
+ md5sums = 6121f1d2fc16d4b9472ddacdef3f8421
+
+pkgname = fahrplan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b57addb9cb8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=fahrplan
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="A SBB/CFF/FFS (Swiss railway) commandline based timetable client"
+url="https://github.com/dbrgn/fahrplan"
+depends=('python' 'python-six' 'python-dateutil' 'python-requests')
+makedepends=('python3' )
+license=('GPLv3')
+arch=('any')
+source=('https://pypi.python.org/packages/source/f/fahrplan/fahrplan-0.2.3.tar.gz')
+md5sums=('6121f1d2fc16d4b9472ddacdef3f8421')
+
+if [ -n "$VIRTUAL_ENV" ]; then
+ echo "Warning: You're building within a virtualenv. Use"
+ echo "a shell without virtualenv to build this package!"
+ exit 1
+fi
+
+
+build() {
+ cd $srcdir/fahrplan-0.2.3
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/fahrplan-0.2.3
+ python setup.py install --root="$pkgdir" --optimize=1
+}