summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-14 10:58:49 +0800
committerzxp198210052023-11-14 10:58:49 +0800
commitde36cdf9a531d934f8e8500bada3db7c189e38a2 (patch)
treee673754ad13e228d182371e106b071bb07889380
parent37b019c5bcce96e2dde486adc8792527d3ec79d8 (diff)
downloadaur-de36cdf9a531d934f8e8500bada3db7c189e38a2.tar.gz
fix errors
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD37
-rw-r--r--fairshare.sh12
3 files changed, 46 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2fb3f0b433c..185f5c35e341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,44 +1,25 @@
pkgbase = fairshare-bin
pkgdesc = Simplifying the curation and sharing of biomedical research data and software according to applicable FAIR guidelines
pkgver = 2.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://fairdataihub.org/fairshare
arch = x86_64
license = MIT
- depends = zlib
- depends = glibc
- depends = bash
+ makedepends = squashfuse
+ depends = electron25
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
depends = libdbusmenu-glib
depends = gtk2
depends = dbus-glib
- depends = gcc-libs
- depends = glib2
- depends = pango
- depends = cairo
- depends = libxdamage
- depends = mesa
- depends = libxext
- depends = libxfixes
- depends = libxrandr
- depends = libxcomposite
- depends = libxcb
- depends = nss
- depends = at-spi2-core
- depends = gtk3
- depends = libxkbcommon
- depends = dbus
- depends = gdk-pixbuf2
- depends = expat
- depends = libcups
- depends = alsa-lib
- depends = libdrm
- depends = libx11
- depends = nspr
provides = fairshare=2.1.0
conflicts = fairshare
source = fairshare-2.1.0.AppImage::https://github.com/fairdataihub/FAIRshare/releases/download/v2.1.0/FAIRshare-2.1.0.AppImage
source = LICENSE::https://raw.githubusercontent.com/fairdataihub/FAIRshare/v2.1.0/LICENSE
+ source = fairshare.sh
sha256sums = 9c6bf87ec638dcb3dc44de81e268a57453f26c4e345023a3664ed0f744c2a7c3
sha256sums = f53ab2779598ebdd8bef9425c402eed3cac0e2a6dc3ec5cbda5a07de0bdcf7dc
+ sha256sums = 6c9d24c3359c40af842c946c5430b94c5abffc6b206476a4ec0b4b7c155c6f3c
pkgname = fairshare-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1f9dd6229e01..1f08630f9351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fairshare-bin
_appname=FAIRshare
pkgver=2.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Simplifying the curation and sharing of biomedical research data and software according to applicable FAIR guidelines"
arch=('x86_64')
url="https://fairdataihub.org/fairshare"
@@ -10,22 +10,37 @@ _githuburl="https://github.com/fairdataihub/FAIRshare"
license=('MIT')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
-depends=('zlib' 'glibc' 'bash' 'libdbusmenu-glib' 'gtk2' 'dbus-glib' 'gcc-libs' 'glib2' 'pango' 'cairo' 'libxdamage' 'mesa' 'libxext' 'libxfixes' 'libxrandr' \
- 'libxcomposite' 'libxcb' 'nss' 'at-spi2-core' 'gtk3' 'libxkbcommon' 'dbus' 'gdk-pixbuf2' 'expat' 'libcups' 'alsa-lib' 'libdrm' 'libx11' 'nspr')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
- "LICENSE::https://raw.githubusercontent.com/fairdataihub/FAIRshare/v${pkgver}/LICENSE")
+depends=(
+ 'electron25'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/fairdataihub/FAIRshare/v${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('9c6bf87ec638dcb3dc44de81e268a57453f26c4e345023a3664ed0f744c2a7c3'
- 'f53ab2779598ebdd8bef9425c402eed3cac0e2a6dc3ec5cbda5a07de0bdcf7dc')
-prepare() {
+ 'f53ab2779598ebdd8bef9425c402eed3cac0e2a6dc3ec5cbda5a07de0bdcf7dc'
+ '6c9d24c3359c40af842c946c5430b94c5abffc6b206476a4ec0b4b7c155c6f3c')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root" -type d -exec chmod 755 {} \;
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
- cp -r "${srcdir}/squashfs-root/"* "${pkgdir}/opt/${pkgname%-bin}"
- ln -sf "/opt/${pkgname%-bin}/AppRun" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/squashfs-root/resources/api" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/fairshare.sh b/fairshare.sh
new file mode 100644
index 000000000000..b60b64c9bcf7
--- /dev/null
+++ b/fairshare.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron25
+APPDIR=/usr/lib/fairshare
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
+cd $APPDIR && ./api 7632
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file