summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Salvia Novella2019-10-29 18:17:36 +0100
committerAlberto Salvia Novella2019-10-29 18:17:36 +0100
commitf4e267374817b1249275566dfced8012a8b8b3b0 (patch)
treec6203edb55069d78380fbcbbdf022615f6e2383d
parente37fe64e37d48e1ec9eb4aa70ee7eba5942ec904 (diff)
downloadaur-f4e267374817b1249275566dfced8012a8b8b3b0.tar.gz
2019-10-29 1572369456
-rwxr-xr-xBUILD67
-rwxr-xr-xPUBLISH54
2 files changed, 0 insertions, 121 deletions
diff --git a/BUILD b/BUILD
deleted file mode 100755
index 2487916b2d24..000000000000
--- a/BUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-#! /bin/bash
-# (GPL3+) Alberto Salvia Novella (es20490446e.wordpress.com)
-
-
-mainFunction () {
- updateInfoFile
- buildPackage
-}
-
-
-buildPackage () {
- removeBuildFiles
- makePackage
- removeBuildFiles
-}
-
-
-changeToThisProgramDir () {
- cd "$( dirname "${BASH_SOURCE[0]}" )"
-}
-
-
-makePackage () {
- nice="nice --adjustment=19"
- ionice="ionice -c2 -n7"
-
- silently "makePackage" "PKGEXT='.pkg.tar.gz' ${nice} ${ionice} makepkg --force"
-}
-
-
-removeBuildFiles () {
- name=$(variableInFile "Name" "PKGBUILD")
- folders="pkg src ${name}"
- silently "removeBuildFiles" "rm --recursive --force ${folders}"
-}
-
-
-silently () {
- function="${1}"
- command="${2}"
- error=$(eval "${command}" 2>&1 >"/dev/null")
-
- if [ ${?} -ne 0 ]; then
- echo "${function}: ${error}" >&2
- exit 1
- fi
-}
-
-
-updateInfoFile () {
- silently "updateInfoFile" "makepkg --printsrcinfo > .SRCINFO"
-}
-
-
-variableInFile () {
- variable="${1}"
- file="${2}"
-
- echo $(
- source "${file}";
- eval echo \$\{${variable}\}
- )
-}
-
-
-changeToThisProgramDir
-mainFunction
diff --git a/PUBLISH b/PUBLISH
deleted file mode 100755
index e606dfd7f694..000000000000
--- a/PUBLISH
+++ /dev/null
@@ -1,54 +0,0 @@
-#! /bin/bash
-# (GPL3+) Alberto Salvia Novella (es20490446e.wordpress.com)
-
-
-mainFunction () {
- summary=$(summary "${1}")
-
- updateInfoFile
- publish "${summary}"
-}
-
-
-changeToThisProgramDir () {
- cd "$( dirname "${BASH_SOURCE[0]}" )"
-}
-
-
-publish () {
- summary="${1}"
-
- silently "publish: add" "git add ."
- git commit --message="${summary}" 2>&1 >"/dev/null"
- silently "publish: push" "git push"
-}
-
-
-silently () {
- function="${1}"
- command="${2}"
- error=$(eval "${command}" 2>&1 >"/dev/null")
-
- if [ ${?} -ne 0 ]; then
- echo "${function}: ${error}" >&2
- exit 1
- fi
-}
-
-
-summary () {
- summary="${1}"
-
- if [ "${summary}" == "" ]; then
- echo $(date "+%Y-%m-%d %s")
- fi
-}
-
-
-updateInfoFile () {
- silently "updateInfoFile" "makepkg --printsrcinfo > .SRCINFO"
-}
-
-
-changeToThisProgramDir
-mainFunction ${@}