summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2020-11-11 11:10:06 +0100
committerOtakar Jašek2020-11-11 11:10:06 +0100
commit198a8d7cecdf336824a950cc42fa54dd2c1abeab (patch)
treedbbe8e26d075c60ddba953bb164a333a1d59f415
parent1c011564836009cfce153a4bda433954e1ebb646 (diff)
downloadaur-198a8d7cecdf336824a950cc42fa54dd2c1abeab.tar.gz
changes in tests
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--tests.patch13
3 files changed, 5 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91ae9a209962..1dcc71aa9ce4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = faiss-cuda-git
- pkgver = 1.6.1.r90.g9873376
+ pkgver = 1.6.1.r142.gfa85ddf
pkgrel = 1
url = https://github.com/facebookresearch/faiss
arch = i686
@@ -10,7 +10,6 @@ pkgbase = faiss-cuda-git
makedepends = python-numpy
makedepends = swig
makedepends = python-setuptools
- makedepends = gcc9
depends = blas
depends = lapack
depends = cuda
@@ -18,10 +17,8 @@ pkgbase = faiss-cuda-git
optdepends = intel-mkl
source = faiss::git+https://github.com/facebookresearch/faiss.git
source = compiler.patch
- source = tests.patch
sha256sums = SKIP
sha256sums = 3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3
- sha256sums = 0e90164da283d87b2ad176449b1ba441b7ce0c6343aa4dbb8d268483bf805ccd
pkgname = faiss-cuda-git
pkgdesc = A library for efficient similarity search and clustering of dense vectors, CUDA version.
diff --git a/PKGBUILD b/PKGBUILD
index 8df1658165c6..5a69b7b307be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,16 +12,14 @@ pkgname=('faiss-cuda-git' 'python-faiss-cuda-git')
arch=('i686' 'x86_64')
url="https://github.com/facebookresearch/faiss"
license=('MIT')
-pkgver=1.6.1.r90.g9873376
+pkgver=1.6.1.r142.gfa85ddf
pkgrel=1
source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git
- 'compiler.patch'
- 'tests.patch')
+ 'compiler.patch')
sha256sums=('SKIP'
- '3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3'
- '0e90164da283d87b2ad176449b1ba441b7ce0c6343aa4dbb8d268483bf805ccd')
+ '3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3')
depends=('blas' 'lapack' 'cuda' 'openmp')
-makedepends=('git' 'python' 'python-numpy' 'swig' 'python-setuptools' 'gcc9')
+makedepends=('git' 'python' 'python-numpy' 'swig' 'python-setuptools')
optdepends=('intel-mkl')
@@ -34,7 +32,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 < ../compiler.patch # see https://github.com/facebookresearch/faiss/issues/1392
- patch -p1 < ../tests.patch # see https://github.com/facebookresearch/faiss/issues/1394
mkdir -p build
cd build
_CMAKE_FLAGS="\
diff --git a/tests.patch b/tests.patch
deleted file mode 100644
index 49a259a10c06..000000000000
--- a/tests.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tests/test_contrib.py b/tests/test_contrib.py
-index 87155e9..ad9f64a 100644
---- a/tests/test_contrib.py
-+++ b/tests/test_contrib.py
-@@ -32,7 +32,7 @@ class TestComputeGT(unittest.TestCase):
- Dnew, Inew = knn_ground_truth(xq, matrix_iterator(xb, 1000), 10)
-
- np.testing.assert_array_equal(Iref, Inew)
-- np.testing.assert_almost_equal(Dref, Dnew, decimal=5)
-+ np.testing.assert_almost_equal(Dref, Dnew, decimal=4)
-
-
- class TestDatasets(unittest.TestCase):