summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2020-09-07 09:26:36 +0200
committerOtakar Jašek2020-09-07 09:26:36 +0200
commit1c011564836009cfce153a4bda433954e1ebb646 (patch)
treef62f105f1c386910a88a5eae118098725c168778
parented83253b98b177b73a22dd288b208eaef8107a92 (diff)
downloadaur-1c011564836009cfce153a4bda433954e1ebb646.tar.gz
couple changes
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 254fa3531cf7..8df1658165c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,9 @@
# Maintainer: otaj <jasek.ota@gmail.com>
-# If you want to set only one GPU target compute capability, set _GPU_TARGET, otherwise leave it commented out and it will build default targets (52, 60, 61, 70 and 75). You can also set multiple targets separated by a space
+# If you want to set only one GPU target compute capability, set _GPU_TARGET,
+# otherwise leave it commented out and it will build default targets (52, 60, 61, 70 and 75).
+# You can also set multiple targets separated by a space
+# If you want the python package to work with MKL, you need to have python-numpy-mkl installed!
+# See https://github.com/facebookresearch/faiss/issues/1393
#_GPU_TARGET="75"
_pkgname=faiss
@@ -53,8 +57,8 @@ prepare() {
check() {
cd "${srcdir}/${_pkgname}/build"
make test
- cd "${srcdir}/${_pkgname}/tests"
- PYTHONPATH=../build/faiss/python:$PYTHONPATH pytest
+ cd "${srcdir}/${_pkgname}"
+ PYTHONPATH=build/faiss/python:$PYTHONPATH pytest
}