summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUnknown2019-03-28 15:44:10 +0100
committerUnknown2019-03-28 15:44:10 +0100
commit45543ee78ef187aa6f19588532443c026e97577d (patch)
tree77e1e1661b17d3e73330d944a9fb7b37d42b6160
parent22822fce6986b7756f7e1ef7f4637e64a5540aaa (diff)
downloadaur-45543ee78ef187aa6f19588532443c026e97577d.tar.gz
Cuda 10.1 patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--cuda10.1.patch14
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92e63b937a2b..1361a0d2f5a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = faiss-cuda-git
- pkgver = v1.5.0.r17.g7b07685
+ pkgver = v1.5.0.r19.ga9959bf
pkgrel = 1
url = https://github.com/facebookresearch/faiss
arch = i686
@@ -16,7 +16,9 @@ pkgbase = faiss-cuda-git
depends = lapack
depends = cuda
source = faiss::git+https://github.com/facebookresearch/faiss.git
+ source = cuda10.1.patch
sha256sums = SKIP
+ sha256sums = b021ca0a3ecfc4cca41e4819a7d8fd0c73a46a3349b1d498d5ad786f1f6a0535
pkgname = faiss-cuda-git
pkgdesc = A library for efficient similarity search and clustering of dense vectors, CUDA version.
diff --git a/PKGBUILD b/PKGBUILD
index 5fb618c1df07..b1f96cb559cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,11 @@ pkgname=('faiss-cuda-git' 'python-faiss-cuda-git' 'python2-faiss-cuda-git')
arch=('i686' 'x86_64')
url="https://github.com/facebookresearch/faiss"
license=('BSD')
-pkgver=v1.5.0.r17.g7b07685
+pkgver=v1.5.0.r19.ga9959bf
pkgrel=1
-source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git)
-sha256sums=('SKIP')
+source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git 'cuda10.1.patch')
+sha256sums=('SKIP'
+ 'b021ca0a3ecfc4cca41e4819a7d8fd0c73a46a3349b1d498d5ad786f1f6a0535')
depends=('blas' 'lapack' 'cuda')
makedepends=('python' 'python2' 'python-numpy' 'python2-numpy' 'swig' 'python-setuptools' 'python2-setuptools')
@@ -26,6 +27,7 @@ prepare() {
cd "${srcdir}/${_pkgname}"
cp -ar python python2
sed -i 's/makefile.inc/makefile2.inc/g' python2/Makefile
+ patch -p1 < ../cuda10.1.patch
}
diff --git a/cuda10.1.patch b/cuda10.1.patch
new file mode 100644
index 000000000000..2100344fde08
--- /dev/null
+++ b/cuda10.1.patch
@@ -0,0 +1,14 @@
+diff --git a/gpu/utils/Tensor.cuh b/gpu/utils/Tensor.cuh
+index f925a37..eba2aa5 100644
+--- a/gpu/utils/Tensor.cuh
++++ b/gpu/utils/Tensor.cuh
+@@ -359,8 +359,7 @@ bool canUseIndexType() {
+
+ template <typename IndexType, typename T, typename... U>
+ bool canUseIndexType(const T& arg, const U&... args) {
+- return arg.canUseIndexType<IndexType>() &&
+- canUseIndexType(args...);
++ return canUseIndexType(args...);
+ }
+
+ } // namespace detail