summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2019-06-20 10:58:54 +0200
committerOtakar Jašek2019-06-20 10:58:54 +0200
commitb6fdba96841dd4e8d0fa3426419590bae3b46f89 (patch)
tree4629fbeae7f136a06581a7f1f3fe682f2664a9da
parentc429b0738f7b538e8f11ab730060f9f9be4ec8c1 (diff)
downloadaur-b6fdba96841dd4e8d0fa3426419590bae3b46f89.tar.gz
Different licensing
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e429c2d547..dc6e781ca3b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = faiss-cuda-git
- pkgver = v1.5.1.r10.g5d1ed5b
+ pkgver = v1.5.2.r5.gd224d11
pkgrel = 1
url = https://github.com/facebookresearch/faiss
arch = i686
arch = x86_64
- license = BSD
+ license = MIT
makedepends = git
makedepends = python
makedepends = python2
diff --git a/PKGBUILD b/PKGBUILD
index 3da5c602407e..904efa6bd9d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgbase=faiss-cuda-git
pkgname=('faiss-cuda-git' 'python-faiss-cuda-git' 'python2-faiss-cuda-git')
arch=('i686' 'x86_64')
url="https://github.com/facebookresearch/faiss"
-license=('BSD')
-pkgver=v1.5.1.r10.g5d1ed5b
+license=('MIT')
+pkgver=v1.5.2.r5.gd224d11
pkgrel=1
source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git)
sha256sums=('SKIP')
@@ -43,6 +43,9 @@ build() {
sh -c "./configure $_CONF_FLAGS --with-python=python2" # what an ugliness! I don't know how to do it better though
mv makefile.inc makefile2.inc
sh -c "./configure $_CONF_FLAGS --with-python=python"
+ make clean
+ make -C python clean
+ make -C python2 clean
make # build faiss
make -C python # build python package
make -C python2 # build python2 package
@@ -54,6 +57,7 @@ package_faiss-cuda-git() {
conflicts=('faiss')
cd "${srcdir}/${_pkgname}"
make DESTDIR="$pkgdir" install
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python-faiss-cuda-git() {
@@ -64,6 +68,7 @@ package_python-faiss-cuda-git() {
cd "${srcdir}/${_pkgname}/python"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_python2-faiss-cuda-git() {
@@ -74,4 +79,5 @@ package_python2-faiss-cuda-git() {
cd "${srcdir}/${_pkgname}/python2"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}