summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2020-03-25 18:49:58 +0100
committerOtakar Jašek2020-03-25 18:49:58 +0100
commitd05dd99061bca042940b8af8992254f6c9889cc2 (patch)
tree11a913457148fda7fb610534ba5de2040881258c
parent97869fdbf1c70e4bf7328744d3e820250a48b7c6 (diff)
downloadaur-d05dd99061bca042940b8af8992254f6c9889cc2.tar.gz
fix build https://github.com/facebookresearch/faiss/issues/1159
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 689c7fac4d9b..45500168f32c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = faiss-cuda-git
- pkgver = v1.6.0.r5.ge325c50
+ pkgver = v1.6.1.r16.gb9914eb
pkgrel = 1
url = https://github.com/facebookresearch/faiss
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index adc44315892a..8a6a8e929543 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: otaj <jasek.ota@gmail.com>
# If you want to set only one GPU target compute capability, set _GPU_TARGET, otherwise leave it commented out and it will build default targets (35, 52, 60 and 61). You can also set multiple targets separated by space (bash array)
-#_GPU_TARGET="61"
+#_GPU_TARGET="75"
_pkgname=faiss
pkgbase=faiss-cuda-git
pkgname=('faiss-cuda-git' 'python-faiss-cuda-git')
arch=('i686' 'x86_64')
url="https://github.com/facebookresearch/faiss"
license=('MIT')
-pkgver=v1.6.0.r5.ge325c50
+pkgver=v1.6.1.r16.gb9914eb
pkgrel=1
source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git)
sha256sums=('SKIP')
@@ -24,11 +24,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
-}
-
-
-build() {
- cd "${srcdir}/${_pkgname}"
+ rm -f gpu/impl/{PQScanMultiPassNoPrecomputed.cu,gpu/impl/PQCodeDistances.cu}
_CONF_FLAGS='--prefix=/usr --with-cuda=/opt/cuda'
if ! [ -z "$_GPU_TARGET" ]
then
@@ -39,8 +35,14 @@ build() {
_CONF_FLAGS=$_CONF_FLAGS'"'
fi
sh -c "./configure $_CONF_FLAGS --with-python=python"
- make # build faiss
- make -C python # build python package
+
+}
+
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make # build faiss
+ make -C python # build python package
}
package_faiss-cuda-git() {