summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPremysl Srubar2021-07-08 01:13:51 +0200
committerPremysl Srubar2021-07-08 01:13:51 +0200
commit2d0b3fb60e2edb78e8a37db7c9db5e18c0e98498 (patch)
treeae3b41486bded1ae2c9922cba19ab391aaa61766
parent0db2bb243e4f9cfe7ddd25f3c8c5b9fc259ab57b (diff)
downloadaur-2d0b3fb60e2edb78e8a37db7c9db5e18c0e98498.tar.gz
Dropped bodypix in favor of python-mediapipe.
-rw-r--r--PKGBUILD51
-rw-r--r--fake-background-webcam@.service3
2 files changed, 11 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04a97169e71a..077c61a53145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
pkgbase=fake-background-webcam-git
_pkgname="${pkgbase%-git}"
-pkgname=('fake-background-webcam-git' 'fake-background-bodypix-git')
-pkgver=r145.b423e09
+pkgname=('fake-background-webcam-git')
+pkgver=r193.5e29493
pkgrel=1
pkgdesc="Virtual background-replacing camera"
-#optdepends=('cuda: for GPU acceleration of the TensorFlow on NVidia cards')
+#'python-cmapy>=0.6.6'
+depends=('v4l2loopback-dkms' 'python' 'python-opencv>=4.4.0.46' 'akvcam-dkms' 'opencv' 'python-numpy>=1.18.2' 'python-requests>=2.23.0' 'python-requests-unixsocket' 'python-aiohttp>=3.6.2' 'python-inotify-simple>=1.2' 'python-pyfakewebcam' 'python-mediapipe')
+provides=('fake-background-webcam')
+conflicts=('fake-background-webcam')
arch=('x86_64')
url="https://github.com/fangfufu/Linux-Fake-Background-Webcam"
license=("GPL")
makedepends=('git' 'npm')
source=("${pkgname}::git+${url}.git"
- 'fake-background-bodypix.service'
'fake-background-webcam@.service'
'readme.md'
"$_pkgname.install")
sha256sums=('SKIP'
- '24827ce9ae57cc11472c26ef4dc8edfa3218250a4ff6bba424f24bfe0eed3cb2'
- '9e8b5fb7fece0b1d2809b5dcb880419e85035f80f8fcaefc9cf9fe56017bf4d9'
+ '848d8ff2700ae616b5c1bb69d99d2fc54427a43ca23b54638aeff99833ac59eb'
'f6b37aff68926eb16c510db56df665ec2a3f8aa7348c0e8ddf247bcaa770a955'
'b57c70f3b498d646d8834d770d806219b306251c908cc8591b0d711e3638916f')
@@ -33,10 +34,9 @@ pkgver() {
}
package_fake-background-webcam-git() {
- depends=('v4l2loopback-dkms' 'python' 'python-opencv' 'akvcam-dkms' 'opencv' 'python-numpy>=1.18.2' 'python-requests>=2.23.0' 'python-requests-unixsocket' 'python-aiohttp>=3.6.2' 'python-pyfakewebcam' 'fake-background-bodypix')
- provides=('fake-background-webcam')
- conflicts=('fake-background-webcam')
- cd "$srcdir/${pkgbase}/fakecam"
+
+
+ cd "$srcdir/${pkgbase}"
install -d "$pkgdir/usr/lib/$_pkgname"
install -Dm644 *.py "$pkgdir/usr/lib/$_pkgname"
@@ -46,34 +46,3 @@ package_fake-background-webcam-git() {
install -v -m 644 -D "${srcdir}/readme.md" "${pkgdir}/usr/share/doc/${_pkgname}/readme.md"
}
-
-
-package_fake-background-bodypix-git() {
- depends=('nodejs>=12')
- provides=('fake-background-bodypix')
- conflicts=('fake-background-bodypix')
-
- install -Dm644 "${srcdir}/fake-background-bodypix.service" "$pkgdir/usr/lib/systemd/system/fake-background-bodypix.service"
-
- #./install.sh
- mkdir -p "${pkgdir}/usr/lib/node_modules"
-
- cd "$srcdir/${pkgbase}/bodypix"
- rm Dockerfile*
- npm pack .
- npm install --user root -g --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" *.tgz
- rm bodypix-*.tgz
-
- # Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/npm/issues/9359 for details.
- find "${pkgdir}"/usr -type d -exec chmod 755 {} +
-
- # npm gives ownership of ALL FILES to build user
- # https://bugs.archlinux.org/task/63396
- chown -R root:root "$pkgdir"
-
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${pkgdir}||" -i {} \;
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${srcdir}||" -i {} \;
-
-
-}
diff --git a/fake-background-webcam@.service b/fake-background-webcam@.service
index 588c1cccc361..0a6994e18d65 100644
--- a/fake-background-webcam@.service
+++ b/fake-background-webcam@.service
@@ -1,7 +1,6 @@
[Unit]
Description =Fake Background Webcam - frame-source /dev/video%i -> /dev/video2%i
-BindsTo=fake-background-bodypix.service
-After=fake-background-bodypix.service
+Requires=dbus.socket
[Service]