summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorschrmh2018-09-18 06:59:40 +0200
committerschrmh2018-09-18 06:59:40 +0200
commit498b6a8da5db3342d44883f4d9fed1ad4ac23461 (patch)
tree613dc852ff4a59152dd96795b929f6c9dd26c568
parentfec5a74bd8cbb3ac091bb8652f686ff1e683b50d (diff)
downloadaur-498b6a8da5db3342d44883f4d9fed1ad4ac23461.tar.gz
removed helper lines that aren't needed anymore and renamed one to helper variable
-rw-r--r--PKGBUILD2
-rwxr-xr-xfakeAUR.sh24
2 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce2d44d7ae49..aca62cbcd853 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hans Müller <schreibemirhalt@gmail.com>
pkgname=fakeaur
-pkgver=r7.9f23531
+pkgver=r8.3254db9
pkgrel=2
pkgdesc="Edit names and descriptions of AUR packages. Meme mates with nani or btwiusearch"
arch=('any')
diff --git a/fakeAUR.sh b/fakeAUR.sh
index bb78aa0b3782..823db204df06 100755
--- a/fakeAUR.sh
+++ b/fakeAUR.sh
@@ -34,9 +34,9 @@ for i in "$@"
echo "and now reduced"
pac=$(echo $processes | grep -o -P "(?<=00:00:00).*(?=$USER)" | grep -o -P "(?<=00:00:00).*(?=00:00:00)")
echo $pac
- one=$(echo $pac | cut -d' ' -f1)
+ helper=$(echo $pac | cut -d' ' -f1)
two=$(echo $pac | cut -d' ' -f2)
- pac=$one" "$two
+ pac=$helper" "$two
echo concat
echo $pac
echo concat end
@@ -55,42 +55,39 @@ for i in "$@"
description=$(echo -ne '\n' | eval "${pac}" | grep " ")
name=$(echo ${pac} | grep -Eo "[^ ]+$")
- helper=$(echo ${pac} | grep -o '^\S*')
echo ${PS1@P}$helper btwiusearch
echo -ne '\n' | eval ${pac} | sed -e "s/$name/btwiusearch/" | sed -e "s/$description/A very important and easy to use package to show the world that you run the best distro/"
;;
-btw )
processes=$(> >(ps -f))
pac=$(echo $processes | grep -o -P "(?<=00:00:00).*(?=$USER)" | grep -o -P "(?<=00:00:00).*(?=00:00:00)")
- one=$(echo $pac | cut -d' ' -f1)
+ helper=$(echo $pac | cut -d' ' -f1)
two=$(echo $pac | cut -d' ' -f2)
- pac=$one" "$two
+ pac=$helper" "$two
description=$(echo -ne '\n' | eval "${pac}" | grep " ")
name=$(echo ${pac} | grep -Eo "[^ ]+$")
- helper=$(echo ${pac} | grep -o '^\S*')
echo ${PS1@P}$helper btwiusearch
echo -ne '\n' | eval ${pac} | sed -e "s/$name/btwiusearch/" | sed -e "s/$description/A very important and easy to use package to show the world that you run the best distro/"
;;
-nani )
processes=$(> >(ps -f))
pac=$(echo $processes | grep -o -P "(?<=00:00:00).*(?=$USER)" | grep -o -P "(?<=00:00:00).*(?=00:00:00)")
- one=$(echo $pac | cut -d' ' -f1)
+ helper=$(echo $pac | cut -d' ' -f1)
two=$(echo $pac | cut -d' ' -f2)
- pac=$one" "$two
+ pac=$helper" "$two
description=$(echo -ne '\n' | eval "${pac}" | grep " ")
name=$(echo ${pac} | grep -Eo "[^ ]+$")
- helper=$(echo ${pac} | grep -o '^\S*')
echo ${PS1@P}$helper nani
echo -ne '\n' | eval ${pac} | sed -e "s/$name/nani/" | sed -e "s/$description/now you can speak japanese/"
;;
-grep)
processes=$(> >(ps -f))
pac=$(echo $processes | grep -o -P "(?<=00:00:00).*(?=$USER)" | grep -o -P "(?<=00:00:00).*(?=00:00:00)")
- one=$(echo $pac | cut -d' ' -f1)
+ helper=$(echo $pac | cut -d' ' -f1)
two=$(echo $pac | cut -d' ' -f2)
- pac=$one" "$two
+ pac=$helper" "$two
description=$(echo -ne '\n' | eval "${pac}" | grep " ")
echo $description
@@ -98,13 +95,12 @@ for i in "$@"
*)
processes=$(> >(ps -f))
pac=$(echo $processes | grep -o -P "(?<=00:00:00).*(?=$USER)" | grep -o -P "(?<=00:00:00).*(?=00:00:00)")
- one=$(echo $pac | cut -d' ' -f1)
+ helper=$(echo $pac | cut -d' ' -f1)
two=$(echo $pac | cut -d' ' -f2)
- pac=$one" "$two
+ pac=$helper" "$two
description=$(echo -ne '\n' | eval "${pac}" | grep " ")
name=$(echo ${pac} | grep -Eo "[^ ]+$")
- helper=$(echo ${pac} | grep -o '^\S*')
echo ${PS1@P}$helper $1
echo -ne '\n' | eval ${pac} | sed -e "s/$name/$1/" | sed -e "s/$description/$2/"
;;