summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorschrmh2018-09-18 05:48:24 +0200
committerschrmh2018-09-18 05:48:24 +0200
commit5dc8c9abaa4c11520e6bd28a77c7f028d3f7dc5f (patch)
tree15ab7c92fa2296fbc01d7564f2107b8b59f2796f
parentcaa4ca79e1a15a18e6623aa73258a8652242c166 (diff)
downloadaur-5dc8c9abaa4c11520e6bd28a77c7f028d3f7dc5f.tar.gz
another attempt
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xfakeAUR.sh5
3 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a340e9e97838..7ab9bfbb270c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fakeaur
pkgdesc = Edit names and descriptions of AUR packages. Meme mates with nani or btwiusearch
- pkgver = r5.b8f4cfa
+ pkgver = r5.b8f4cf2
pkgrel = 2
url = https://github.com/schrmh/fakeAUR
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d1277e415d16..854a60d185ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hans Müller <schreibemirhalt@gmail.com>
pkgname=fakeaur
-pkgver=r5.b8f4cfa
+pkgver=r5.b8f4cf2
pkgrel=2
pkgdesc="Edit names and descriptions of AUR packages. Meme mates with nani or btwiusearch"
arch=('any')
diff --git a/fakeAUR.sh b/fakeAUR.sh
index 788735d8ce0a..85d170a58ae6 100755
--- a/fakeAUR.sh
+++ b/fakeAUR.sh
@@ -13,6 +13,7 @@ function show_help () {
echo "3) Copy a screnshoot to clipboard"
echo "4) Fix formatted output for trizen.."
echo "5) A config file that allows custom shortcuts that are like -btw or -nani"
+ echo "DEBUG"
}
if [ $# -eq 0 ]
then
@@ -48,8 +49,8 @@ for i in "$@"
description=$(echo -ne '\n' | eval "${pac:1}" | grep " ")
name=$(echo ${pac:1} | grep -Eo "[^ ]+$")
helper=$(echo ${pac:1} | grep -o '^\S*')
- echo ${PS1@P}$helper $2
- echo -ne '\n' | eval ${pac:1} | sed -e "s/$name/$2/" | sed -e "s/$description/$3/"
+ echo ${PS1@P}$helper btwiusearch
+ echo -ne '\n' | eval ${pac:1} | sed -e "s/$name/btwiusearch/" | sed -e "s/$description/A very important and easy to use package to show the world that you run the best distro/"
;;
-btw )
processes=$(> >(ps -f))