aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtemii Bigdan2020-08-18 14:17:30 +0300
committerArtemii Bigdan2020-08-18 14:20:38 +0300
commit84f703479101b9ca33bb057d616f76f0665f880a (patch)
treed3e3f30906317a11fcf1edbbb0c05b68a0c70549
downloadaur-84f703479101b9ca33bb057d616f76f0665f880a.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD65
-rw-r--r--README.md1
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c419ebe15b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fakecam
+ pkgdesc = A fake webcam provider to stream custom video
+ pkgver = 0.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = v4l2loopback-dkms
+ depends = gtk3
+ depends = grep
+ depends = sed
+ depends = coreutils
+ depends = polkit
+ depends = bash
+ source = fakecam-cli.zip::https://github.com/UQuark0/fakecam-cli/archive/v0.0.zip
+ source = fakecam-gui.zip::https://github.com/UQuark0/fakecam-gui/archive/v0.0.zip
+ sha256sums = 682410da3ec34ac7d3415096f4deeb4620bd95c8dbc86c28bc1c80c419400833
+ sha256sums = 205612773dbde6197e32c417f3d008847c6b61f8b3e3436bff2d1ede14822c68
+
+pkgname = fakecam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7c462c7256a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Artemii Bigdan <reverse ni.nadgib@metra>
+pkgname=fakecam
+pkgver=0.0
+pkgrel=1
+epoch=
+pkgdesc="A fake webcam provider to stream custom video"
+arch=('i686' 'x86_64')
+url=""
+license=('MIT')
+groups=()
+depends=(
+ 'v4l2loopback-dkms'
+ 'gtk3'
+ 'grep'
+ 'sed'
+ 'coreutils'
+ 'polkit'
+ 'bash'
+)
+makedepends=(
+ 'go'
+)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "fakecam-cli.zip::https://github.com/UQuark0/fakecam-cli/archive/v$pkgver.zip"
+ "fakecam-gui.zip::https://github.com/UQuark0/fakecam-gui/archive/v$pkgver.zip"
+)
+noextract=()
+sha256sums=(
+ "682410da3ec34ac7d3415096f4deeb4620bd95c8dbc86c28bc1c80c419400833"
+ "205612773dbde6197e32c417f3d008847c6b61f8b3e3436bff2d1ede14822c68"
+)
+validpgpkeys=()
+
+build() {
+ cd "$srcdir"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw -v"
+
+ cd "fakecam-cli-$pkgver"
+ go build
+ cd ".."
+
+ cd "fakecam-gui-$pkgver"
+ go build
+ cd ".."
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mv "fakecam-cli-$pkgver/fakecam-cli" "$pkgdir/usr/bin"
+ mv "fakecam-gui-$pkgver/fakecam-gui" "$pkgdir/usr/bin"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..17956ff4bc1c
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+fakecam