aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtemii Bigdan2020-08-19 13:55:23 +0300
committerArtemii Bigdan2020-08-19 13:55:27 +0300
commitf85bb135c21e66aeb1c907e035802580f891e5a3 (patch)
tree2c80f31ebe2505f369e23d1a9c63c15d3a02efdd
downloadaur-f85bb135c21e66aeb1c907e035802580f891e5a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
-rw-r--r--README.md1
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..611689df1041
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fakecam-cli
+ pkgdesc = A fake webcam provider to stream custom video
+ pkgver = 0.0
+ pkgrel = 3
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = v4l2loopback-dkms
+ source = fakecam-cli-v0.0.zip::https://github.com/UQuark0/fakecam-cli/archive/v0.0.zip
+ sha256sums = 682410da3ec34ac7d3415096f4deeb4620bd95c8dbc86c28bc1c80c419400833
+
+pkgname = fakecam-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cc617df54a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Artemii Bigdan <reverse ni.nadgib@metra>
+pkgname=fakecam-cli
+pkgver=0.0
+pkgrel=3
+pkgdesc="A fake webcam provider to stream custom video"
+arch=('i686' 'x86_64')
+license=('MIT')
+groups=()
+depends=(
+ 'v4l2loopback-dkms'
+)
+makedepends=(
+ 'go'
+)
+source=(
+ "fakecam-cli-v$pkgver.zip::https://github.com/UQuark0/fakecam-cli/archive/v$pkgver.zip"
+)
+sha256sums=(
+ "682410da3ec34ac7d3415096f4deeb4620bd95c8dbc86c28bc1c80c419400833"
+)
+
+build() {
+ cd "$srcdir"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw -v"
+
+ cd "fakecam-cli-$pkgver"
+ go build
+ cd ".."
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mv "fakecam-cli-$pkgver/fakecam-cli" "$pkgdir/usr/bin"
+
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ mv "fakecam-cli-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5b6699d00e34
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+fakecam-cli