summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-07-15 19:46:05 +0000
committerPellegrino Prevete2022-07-15 19:46:05 +0000
commit6cfc799f4c2a3a0780a10e2436ac20fef8c809d9 (patch)
tree6d94c3bc4a8f0430851162ae8d80bff8440e2c23
parent1ba1f5c992649808c72fc52929a3d6f667b451e7 (diff)
downloadaur-6cfc799f4c2a3a0780a10e2436ac20fef8c809d9.tar.gz
fix pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a98848e453b..635ad5c8497a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fakepkg-git
pkgdesc = Tool to reassemble installed packages from its deliverd files. It comes in handy if there is no internet connection available and you have no access to an up-to-date package cache
- pkgver = 1.42.0
+ pkgver = v1.42.0
pkgrel = 1
url = https://github.com/Edenhofer/fakepkg
arch = any
@@ -15,6 +15,6 @@ pkgbase = fakepkg-git
provides = fakepkg
conflicts = fakepkg
source = fakepkg::git+https://gitlab.archlinux.org/tallero/fakepkg
- sha512sums = SKIP
+ sha256sums = SKIP
pkgname = fakepkg-git
diff --git a/PKGBUILD b/PKGBUILD
index 797f7902b2d8..990062457899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# shellcheck disable=SC2034
_pkgname=fakepkg
pkgname="${_pkgname}-git"
-pkgver=1.42.0
+pkgver=v1.42.0
pkgrel=1
pkgdesc="Tool to reassemble installed packages from its deliverd files. It comes in handy if there is no internet connection available and you have no access to an up-to-date package cache"
arch=('any')
@@ -12,11 +12,16 @@ license=('AGPL3')
url="https://github.com/Edenhofer/fakepkg"
_url="https://gitlab.archlinux.org/tallero/${_pkgname}"
depends=('bash>=4.2' 'pacman' 'tar' 'gzip' 'sed' 'awk')
-makedepends=("git")
+makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+${_url}")
-sha512sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
package() {
cd "${srcdir}/${_pkgname}"