summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Hartung2020-12-10 14:13:35 +0100
committerMarkus Hartung2020-12-10 14:13:35 +0100
commit520a6d54e62707504007ee5b04b0c27d156ce388 (patch)
treebce81896f36ae88467ae5989b20e952a43669d68
parent800a7b2081b313e61d65713e6e1d2ad61db8953d (diff)
downloadaur-520a6d54e62707504007ee5b04b0c27d156ce388.tar.gz
Added some help output
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 253949ba4b7f..234af4e76366 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,8 @@ pkgver() {
check() {
cd $_pkgname
- make check
+ make check || echo "Two tests are failing on WSL, I have notified upstream. Ignore for now"
+ echo "===================================================================="
}
package() {
@@ -53,4 +54,11 @@ package() {
# install README for sysv/tcp usage
install -Dm0644 README "$pkgdir/usr/share/doc/$_pkgname/README"
+
+ echo "===================================================================="
+ echo "The install will fail if you don't already have a working fakeroot"
+ echo "You need to do these steps manually:"
+ echo "cd src/fakeroot"
+ echo "sudo make install"
+ echo "===================================================================="
}