summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2018-03-16 20:54:21 +0100
committergrufo2018-03-16 20:54:21 +0100
commitf73cae4acfedd3f534a8a8bb88aec50c46e8eda0 (patch)
tree1f7ec9014c97a04433ccf6b5448124db537dbf69
parentfadc33bf477c3dbb45b6ca65c457b02c560bf304 (diff)
downloadaur-f73cae4acfedd3f534a8a8bb88aec50c46e8eda0.tar.gz
Added `fakeuser.patch` to `${source}`
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
-rw-r--r--fakeuser.patch11
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a87bc6992383..56765d1ecf5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,9 @@ pkgbase = fakeuser-git
provides = fakeuser
conflicts = fakeuser
source = git+https://github.com/progandy/fakeuser.git
+ source = fakeuser.patch
md5sums = SKIP
+ md5sums = db7536ff3a3d751ea9dd5f7580b610d1
pkgname = fakeuser-git
diff --git a/PKGBUILD b/PKGBUILD
index 15c0009d9bca..8c13f71babdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,10 @@ license=('GPL')
depends=('bash')
provides=("${_appname}")
conflicts=("${_appname}")
-source=("git+https://github.com/progandy/${_appname}.git")
-md5sums=('SKIP')
+source=("git+https://github.com/progandy/${_appname}.git"
+ 'fakeuser.patch')
+md5sums=('SKIP'
+ 'db7536ff3a3d751ea9dd5f7580b610d1')
pkgver() {
@@ -22,6 +24,13 @@ pkgver() {
}
+prepare() {
+
+ cd "${srcdir}/${_appname}"
+ patch -p0 < "${srcdir}/fakeuser.patch"
+
+}
+
build() {
cd "${srcdir}/${_appname}"
@@ -36,8 +45,8 @@ package() {
install -dm755 "${pkgdir}/usr/bin"
install -Dm755 'fakeadd' "${pkgdir}/usr/bin/fakeadd"
- install -Dm755 'fakeuser' "${pkgdir}/usr/bin/"
- install -Dm755 'libfakeuser.so' "${pkgdir}/usr/lib/${_appname}/libfakeuser.so"
+ install -Dm755 'fakeuser' "${pkgdir}/usr/bin/fakeuser"
+ install -Dm755 'libfakeuser.so' "${pkgdir}/usr/lib/lib${_appname}/libfakeuser.so"
cp 'example-makepkg/'* "${pkgdir}/usr/share/doc/${_appname}/example-makepkg"
install -Dm644 "${srcdir}/${_appname}/"{README.md,LICENSE} "${pkgdir}/usr/share/doc/${_appname}"
diff --git a/fakeuser.patch b/fakeuser.patch
new file mode 100644
index 000000000000..73b35f186f45
--- /dev/null
+++ b/fakeuser.patch
@@ -0,0 +1,11 @@
+--- fakeuser 2018-03-16 20:33:21.101608444 +0100
++++ aur-fakeuser 2018-03-16 20:31:28.549404000 +0100
+@@ -26,7 +26,7 @@
+ exit
+ fi
+
+-LIB="libfakeuser.so"
++LIB="/usr/lib/libfakeuser/libfakeuser.so"
+
+ # Keep preloaded libs
+ if test -n "$LD_PRELOAD"; then