aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Schmitt2016-05-06 08:37:36 +0200
committerPhilipp Schmitt2016-05-06 08:37:36 +0200
commit98dc6d4bb6079b69c2abfad97db136d6b8b716fc (patch)
treecf8b36796aee37249d1df634795d0feea53c0677
parent7cdb7207136ca28c5ec55e0b15f30f312e503774 (diff)
downloadaur-98dc6d4bb6079b69c2abfad97db136d6b8b716fc.tar.gz
Set the PREFIX more elegantly
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6e5c94294b5..44f42f01241f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 6 06:31:11 UTC 2016
+# Fri May 6 06:37:10 UTC 2016
pkgbase = fakexrandr-git
pkgdesc = Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr
pkgver = r68.bb5ee75
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/phillipberndt/fakexrandr
arch = any
license = GPL
@@ -12,7 +12,7 @@ pkgbase = fakexrandr-git
makedepends = sed
makedepends = python2
depends = xorg-xrandr
- source = fakexrandr-git::git://github.com/phillipberndt/fakexrandr.git
+ source = fakexrandr-git::git+https://github.com/phillipberndt/fakexrandr.git
sha1sums = SKIP
pkgname = fakexrandr-git
diff --git a/PKGBUILD b/PKGBUILD
index 8d6904da0475..73e7d0b60622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Upstream: https://github.com/phillipberndt/fakexrandr
pkgname=fakexrandr-git
pkgver=r68.bb5ee75
-pkgrel=1
+pkgrel=2
pkgdesc="Fake XRandR configurations for multi-head setups with crappy video drivers, like fakexinerama but with xrandr"
arch=(any)
url="https://github.com/phillipberndt/fakexrandr"
license=('GPL')
depends=('xorg-xrandr')
makedepends=('git' 'glibc' 'sed' 'python2')
-source=("$pkgname"::'git://github.com/phillipberndt/fakexrandr.git')
+source=("$pkgname"::'git+https://github.com/phillipberndt/fakexrandr.git')
sha1sums=('SKIP')
_pkgname=fakexrandr
@@ -31,7 +31,6 @@ prepare() {
sed -i "s|\(install\) \(.*\) \(.*\);|\1 \2 \3/\2;|" Makefile
# Fix missing DEST_DIR in Makefile
sed -i "s|\(TARGET_DIR=\).*|\1${pkgdir}${_lib_dir}; \\\|" Makefile
- sed -i "s|\(PREFIX=\).*|\1${pkgdir}\/usr|" Makefile
# Don't even try to run ldconfig now
sed -i "s/\(ldconfig\)/#\1/" Makefile
# Create ld.so.conf.d config file
@@ -47,7 +46,7 @@ build() {
package() {
cd "$srcdir/$pkgname"
mkdir -p "$pkgdir/$_lib_dir" "${pkgdir}/usr/bin"
- make install
+ make PREFIX="$pkgdir/usr" install
install -D -m 644 "${_pkgname}.conf" "$pkgdir/etc/ld.so.conf.d/${_pkgname}.conf"
}