summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2019-06-16 00:03:20 +0300
committerJonian Guveli2019-06-16 00:03:20 +0300
commitcc5b93ff3993a3d20ff483b894b7ebd887f658d2 (patch)
treec27a9aaabf4d673ca6c43f2c81469535a26e7579
downloadaur-cc5b93ff3993a3d20ff483b894b7ebd887f658d2.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa987f0342ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = faktory-bin
+ pkgdesc = High-performance job processing for the polyglot enterprise
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/contribsys/faktory
+ arch = x86_64
+ license = GPL3
+ depends = redis
+ provides = faktory
+ conflicts = faktory
+ conflicts = faktory-git
+ source = faktory-bin-1.0.1.deb::https://github.com/contribsys/faktory/releases/download/v1.0.1-1/faktory_1.0.1-1_amd64.deb
+ sha256sums = 9383024b6e3e3d18e4a892755e4fe3a7c7ad2e74af1c16b22da5d86e85b85e95
+
+pkgname = faktory-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b417cdd4b02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=faktory-bin
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="High-performance job processing for the polyglot enterprise"
+arch=("x86_64")
+url="https://github.com/contribsys/faktory"
+license=("GPL3")
+depends=("redis")
+provides=("faktory")
+conflicts=("faktory" "faktory-git")
+source=("$pkgname-$pkgver.deb::$url/releases/download/v$pkgver-1/faktory_$pkgver-1_amd64.deb")
+sha256sums=("9383024b6e3e3d18e4a892755e4fe3a7c7ad2e74af1c16b22da5d86e85b85e95")
+
+prepare() {
+ bsdtar xf data.tar.bz2
+}
+
+package() {
+ mv usr "$pkgdir"
+}