summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2015-06-21 19:23:44 +0200
committerrevel2015-06-21 19:23:44 +0200
commit11516ce6c21878f1be4a9afeebc4a82b83bac07b (patch)
tree916483ce450f0bebe4ec9885cadd1b5cb91bfa74
downloadaur-11516ce6c21878f1be4a9afeebc4a82b83bac07b.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faf1e1cc1110
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = falcon
+ pkgdesc = a general purpose untyped language, based on a Virtual Machine executing portable pseudo codes
+ pkgver = 0.9.6.8
+ pkgrel = 3
+ url = http://falconpl.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom:FPLLv1.1
+ makedepends = cmake
+ depends = bison
+ depends = gtk2
+ depends = gd
+ depends = curl
+ depends = dbus-core
+ depends = sdl_image
+ depends = sdl_ttf
+ depends = sdl_mixer
+ depends = sqlite
+ depends = libmysqlclient
+ depends = postgresql-libs
+ source = http://falconpl.org/project_dl/_official_rel/Falcon-0.9.6.8.tgz
+ md5sums = 8435f6f2fe95097ac2fbe000da97c242
+ sha256sums = f4b00983e7f91a806675d906afd2d51dcee048f12ad3af4b1dadd92059fa44b9
+
+pkgname = falcon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe1246430a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: revel <revelΘmuub·net>
+# Contributor: Jeremy Cowgar <jeremy@cowgar.com>
+
+pkgname=falcon
+pkgver=0.9.6.8
+pkgrel=3
+pkgdesc='a general purpose untyped language, based on a Virtual Machine executing portable pseudo codes'
+arch=('i686' 'x86_64')
+url='http://falconpl.org'
+license=('GPL2'
+ 'custom:FPLLv1.1')
+depends=('bison' 'gtk2' 'gd' 'curl' 'dbus-core' 'sdl_image' 'sdl_ttf' 'sdl_mixer' 'sqlite' 'libmysqlclient' 'postgresql-libs')
+makedepends=('cmake')
+source=("http://falconpl.org/project_dl/_official_rel/Falcon-$pkgver.tgz"
+# 'mongodb-module.patch'
+ )
+md5sums=('8435f6f2fe95097ac2fbe000da97c242')
+sha256sums=('f4b00983e7f91a806675d906afd2d51dcee048f12ad3af4b1dadd92059fa44b9')
+
+prepare() {
+ cd "Falcon-$pkgver"
+# patch -p1 -i ../mongodb-module.patch
+}
+
+build() {
+ cd "Falcon-$pkgver"
+ [ -d build ] || mkdir build
+ cd build
+
+ # mongodb module disabled due to compilation problems
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DFALCON_BUILD_MONGODB=Off
+
+ make
+}
+
+package() {
+ cd "Falcon-$pkgver/build"
+ make install DESTDIR="$pkgdir/"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/falcon/LICENSE"
+}