summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbl00dy18372021-07-09 21:33:52 +0200
committerbl00dy18372021-07-09 21:33:52 +0200
commita935d337594659b9280a2dc915fd2dbcd48124dd (patch)
tree15b28de18d5a3143314f9ab00d5112be3ea395f3
downloadaur-a935d337594659b9280a2dc915fd2dbcd48124dd.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--fallingtime.desktop9
-rw-r--r--fallingtime.sh3
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49fa706ad7bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = fallingtime-git
+ pkgdesc = Arcade game inspired by Fall Down. SDL 2, PC or OpenDingux.
+ pkgver = r96.9cc480b
+ pkgrel = 1
+ url = https://github.com/cxong/FallingTime
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ source = fallingtime::git+https://github.com/cxong/FallingTime.git
+ source = fallingtime.sh
+ source = fallingtime.desktop
+ sha256sums = SKIP
+ sha256sums = 2213caa4bb13f483b61a6ea57ee0f74394080505720d004a476ed10651150fc7
+ sha256sums = e7c80c605000bedabb5cd0c415539288f2a3cc01246e84364dbdac2742a81414
+
+pkgname = fallingtime-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..971424b72c75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+
+_pkgname=fallingtime
+pkgname=${_pkgname}-git
+pkgver=r96.9cc480b
+pkgrel=1
+pkgdesc="Arcade game inspired by Fall Down. SDL 2, PC or OpenDingux."
+arch=('any')
+url="https://github.com/cxong/FallingTime"
+license=('GPL2')
+makedepends=('git' 'cmake')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+source=("${_pkgname}::git+https://github.com/cxong/FallingTime.git"
+ "${_pkgname}.sh"
+ "${_pkgname}.desktop")
+sha256sums=('SKIP'
+ '2213caa4bb13f483b61a6ea57ee0f74394080505720d004a476ed10651150fc7'
+ 'e7c80c605000bedabb5cd0c415539288f2a3cc01246e84364dbdac2742a81414')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake .
+ make
+}
+
+package() {
+ install -Dm644 "${srcdir}/${_pkgname}/COPYRIGHT" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install "${srcdir}/${_pkgname}/falling_time" -Dm755 "${pkgdir}/opt/${_pkgname}/${_pkgname}"
+ cp -r "${srcdir}/${_pkgname}/data" "${pkgdir}/opt/${_pkgname}/"
+ install "${startdir}/${_pkgname}.sh" -Dm755 "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${startdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+}
diff --git a/fallingtime.desktop b/fallingtime.desktop
new file mode 100644
index 000000000000..b0c39fcea21f
--- /dev/null
+++ b/fallingtime.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+
+Name=Falling Time
+Comment=Arcade game inspired by Fall Down.
+Exec=fallingtime
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=games;
diff --git a/fallingtime.sh b/fallingtime.sh
new file mode 100644
index 000000000000..f70e666d5cf1
--- /dev/null
+++ b/fallingtime.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/fallingtime
+./fallingtime