summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Klevtsov2020-05-07 11:19:58 +0700
committerArtem Klevtsov2020-05-07 11:19:58 +0700
commita305895e935077035534fd81f6727a6cf00d105b (patch)
tree1c7b50029dd6dfd1753e3f9f84f93f6e568f7747
parentf546a5e1ea78580b6b2432ebf8c8fe4833fec3ca (diff)
downloadaur-a305895e935077035534fd81f6727a6cf00d105b.tar.gz
Small fixes
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dd960856e14..699583fcfa1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,7 @@ pkgbase = fancon
depends = lm_sensors
depends = grpc
depends = boost-libs
+ conflicts = fancon-git
source = https://github.com/hbriese/fancon/archive/0.20.1.tar.gz
sha512sums = fb78409417d3a8d623bc2da3f12fab8f42ea62e49f191b200af818185f4304cd7ddb0bc91e580c54c145d95d1d691a2def54c097bdd4192a860ec52d2b53c47a
diff --git a/PKGBUILD b/PKGBUILD
index 52be1d9196b1..160cb85613d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ pkgdesc="A Linux fan control daemon"
arch=('x86_64')
url="https://github.com/hbriese/${pkgname}"
license=('Apache')
-depends=()
depends=('lm_sensors' 'grpc' 'boost-libs')
makedepends=('clang>=9.0' 'cmake>=3.13' 'boost' 'protobuf' 'libx11' 'pstreams' 'libxnvctrl')
source=("https://github.com/hbriese/${pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('fb78409417d3a8d623bc2da3f12fab8f42ea62e49f191b200af818185f4304cd7ddb0bc91e580c54c145d95d1d691a2def54c097bdd4192a860ec52d2b53c47a')
+conflicts=("${pkgname}-git")
build() {
rm -rf "${srcdir}/${pkgname}-${pkgver}/build"
@@ -19,7 +19,6 @@ build() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
export CC=clang
export CXX=clang++
- export CCACHE_DISABLE=1
cmake -DCMAKE_BUILD_TYPE=Release \
-DNVIDIA_SUPPORT=ON \
-DCMAKE_INSTALL_PREFIX=/usr \