summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandra2022-10-27 04:57:19 -0600
committerAlexandra2022-10-27 04:57:19 -0600
commit74daf299e402592588c94b3e80afaa7bb4fe918a (patch)
tree3e780d9f0d527f81e2b328817d30bb5ae4c4db85
downloadaur-74daf299e402592588c94b3e80afaa7bb4fe918a.tar.gz
initalize repository and create pkg
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d428bd58b6f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fancytasks
+ pkgdesc = More modern style taskbar-style window switcher displaying icons and text, with some improvments
+ pkgver = 1.0.0.r1.g9d66a69
+ pkgrel = 1
+ url = https://github.com/alexankitty/FancyTasks
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = plasma-workspace
+ provides = fancytasks
+ conflicts = provides
+ source = git+https://github.com/alexankitty/FancyTasks.git
+ sha512sums = SKIP
+
+pkgname = fancytasks
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19caf87401ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alexandra Stone <ideas@alexankitty.com>
+pkgname="fancytasks"
+pkgver=1.0.0.r1.g9d66a69
+pkgrel=1
+pkgdesc="More modern style taskbar-style window switcher displaying icons and text, with some improvments"
+arch=(any)
+url="https://github.com/alexankitty/FancyTasks"
+license=(GPL)
+depends=(plasma-workspace)
+makedepends=(git)
+provides=(fancytasks)
+conflicts=(provides)
+source=("git+https://github.com/alexankitty/FancyTasks.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd FancyTasks
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _pkgdir="$pkgdir/usr/share/plasma/plasmoids/alexankitty.fancytasks"
+ _iconpkgdir="$pkgdir/usr/share/icons/hicolor/256x256/apps"
+ mkdir -p "$_pkgdir"
+ mkdir -p "$_iconpkgdir"
+ cp FancyTasks/FancyTasks.png "$_iconpkgdir"
+
+ cp -r FancyTasks/* "$_pkgdir"
+ rm "$_pkgdir/README.MD"
+ rm "$_pkgdir/install.sh"
+ rm "$_pkgdir/FancyTasks.png"
+}