summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 19:15:52 +0200
committerAntonio Rojas2022-04-01 19:15:52 +0200
commit8d7fcc2bad5ced45a2ac4b0180e5b2c4cf997e94 (patch)
tree62f65a9e9bd6cbbb630f60fe27c513c366aa020c
parent65db4d844dc27a0c135570b04e141ad4c094c712 (diff)
downloadaur-8d7fcc2bad5ced45a2ac4b0180e5b2c4cf997e94.tar.gz
import from community
-rw-r--r--.SRCINFO25
-rw-r--r--0001-makeplugin-do-not-bundle-system-dependencies.patch37
-rw-r--r--PKGBUILD37
-rw-r--r--changelog.txt104
4 files changed, 123 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f6f54859657..95d0eaa6dace 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,25 @@
pkgbase = fanficfare
pkgdesc = A tool for downloading fanfiction to eBook formats
- pkgver = 2.28.0
+ pkgver = 4.10.0
pkgrel = 1
url = https://github.com/JimmXinu/FanFicFare
changelog = changelog.txt
arch = any
license = Apache
- depends = python2
- depends = python2-beautifulsoup4
- depends = python2-chardet
- depends = python2-html5lib
- depends = python2-html2text
- source = fanficfare-2.28.0.tar.gz::https://github.com/JimmXinu/FanFicFare/archive/v2.28.0.tar.gz
- sha256sums = 7c53a92787435edd070b8cece684d845d0d5b4bc973ca1b84eff2be593ee2ca2
+ depends = python-beautifulsoup4
+ depends = python-brotli
+ depends = python-chardet
+ depends = python-cloudscraper
+ depends = python-html5lib
+ depends = python-html2text
+ depends = python-requests-file
+ optdepends = calibre: use FanFicFare as a calibre plugin
+ optdepends = python-pillow: support for converting/resizing story images and covers
+ source = fanficfare-4.10.0.tar.gz::https://github.com/JimmXinu/FanFicFare/archive/v4.10.0.tar.gz
+ source = 0001-makeplugin-do-not-bundle-system-dependencies.patch
+ sha256sums = f4717a9f1eb76b7b94749f7984b454ac51707f1b06d90ddbe9345ad80a672edd
+ sha256sums = 6d172dcc98a8f6dcef2048272bfabd810ceeb5740969fbe406ebcd7b638e072c
+ b2sums = 96e2750e3e3d21b1e6700ca5a9ceaea20964b516c34599644de44f41d284e3270ae62e54b07bbb98e52a1efb3ccf210443b7ee57f701032eeee033a144cc4d51
+ b2sums = eca0e505305ef74e0af1be6f5c1376091da4cd69bfc9f468f6040cf35d71890e3901b9cf0a9f9e25e6cb409651d402d8414116d0a8d43269bfdab2fdd0005279
pkgname = fanficfare
-
diff --git a/0001-makeplugin-do-not-bundle-system-dependencies.patch b/0001-makeplugin-do-not-bundle-system-dependencies.patch
new file mode 100644
index 000000000000..af1ef325178d
--- /dev/null
+++ b/0001-makeplugin-do-not-bundle-system-dependencies.patch
@@ -0,0 +1,37 @@
+From a483e39777470538e2e94cb5048b3dc370a35e83 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Sun, 18 Apr 2021 15:35:15 -0400
+Subject: [PATCH] makeplugin: do not bundle system dependencies
+
+---
+ makeplugin.py | 12 +-----------
+ 1 file changed, 1 insertion(+), 11 deletions(-)
+
+diff --git a/makeplugin.py b/makeplugin.py
+index 6ee101fb..e6f7c20c 100644
+--- a/makeplugin.py
++++ b/makeplugin.py
+@@ -34,19 +34,9 @@ if __name__=="__main__":
+ files,
+ exclude=exclude)
+
+- os.chdir('../included_dependencies')
+- files=['bs4','chardet','html2text','soupsieve','backports',
+- 'cloudscraper','requests','requests_toolbelt',
+- 'requests_file.py','urllib3','certifi','idna','brotlidecpy']
+- ## Kept only for v2.85.1 support now.
+- createZipFile("../"+filename,"a",
+- files,
+- exclude=exclude)
+-
+ os.chdir('..')
+ # 'a' for append
+ files=['fanficfare']
+ createZipFile(filename,"a",
+ files,
+- exclude=exclude)
+-
++ exclude=exclude + ['*.py'])
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 449c22cd7176..c20b89dd1357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,46 @@
# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
-# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
-
_pkgname=FanFicFare
pkgname=fanficfare
-pkgver=2.28.0
+pkgver=4.10.0
pkgrel=1
pkgdesc="A tool for downloading fanfiction to eBook formats"
arch=('any')
url="https://github.com/JimmXinu/${_pkgname}"
license=('Apache')
changelog=changelog.txt
-depends=('python2' 'python2-beautifulsoup4' 'python2-chardet' 'python2-html5lib'
- 'python2-html2text')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('7c53a92787435edd070b8cece684d845d0d5b4bc973ca1b84eff2be593ee2ca2')
+_deps=('beautifulsoup4' 'brotli' 'chardet' 'cloudscraper' 'html5lib' 'html2text'
+ 'requests-file')
+depends=("${_deps[@]/#/python-}")
+optdepends=('calibre: use FanFicFare as a calibre plugin'
+ 'python-pillow: support for converting/resizing story images and covers')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "0001-makeplugin-do-not-bundle-system-dependencies.patch")
+sha256sums=('f4717a9f1eb76b7b94749f7984b454ac51707f1b06d90ddbe9345ad80a672edd'
+ '6d172dcc98a8f6dcef2048272bfabd810ceeb5740969fbe406ebcd7b638e072c')
+b2sums=('96e2750e3e3d21b1e6700ca5a9ceaea20964b516c34599644de44f41d284e3270ae62e54b07bbb98e52a1efb3ccf210443b7ee57f701032eeee033a144cc4d51'
+ 'eca0e505305ef74e0af1be6f5c1376091da4cd69bfc9f468f6040cf35d71890e3901b9cf0a9f9e25e6cb409651d402d8414116d0a8d43269bfdab2fdd0005279')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ patch -p1 -i ../0001-makeplugin-do-not-bundle-system-dependencies.patch
+}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python2 setup.py build
+
+ python setup.py build
+
+ for i in calibre-plugin/translations/*.po; do
+ msgfmt -vv "$i" -o "${i%.po}.mo"
+ done
+ python makeplugin.py
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 FanFicFare.zip "${pkgdir}"/usr/share/calibre/system-plugins/FanFicFare.zip
}
diff --git a/changelog.txt b/changelog.txt
index d6d6cd55248a..076b66d0128e 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -1,63 +1,43 @@
-Version 2.28.0 - 02 Aug 2018
-- Fix html appearing in txt summary by default.
-- Remove in-story ad links from adapter_asexstoriescom.
-- adapter_royalroadl site uses relative dates now, including months and years
- ago.
-- Update plugin & web service html2text included package to fix text <>&
- output.
-- Fix for corner case screwing up chapter html(attr quotes). Closes #324
-- adapter_webnovelcom: update title selection (#323), thanks Ea
-- Remove accidental file.
-- Change AO3 description blockquote to a div tag.
-- Fix section links in html output(broken in def6b39)
-- Remove Google Plus icon (web service only)
-- Fix base_xenforoforum_adapter bug when no threadmarks.
-- Get fanficauthors.net story URL from existing epubs downloaded from the
- site.
-- Fix for site change: adapter_wuxiaworldcom
-- Add note to use_threadmark_wordcounts setting--base_xenforo sites'
- wordcounts ignore words insite Spoiler tags.
-- adapter_wuxiaworldco: Some older stories use a different date format.
-- Fix origtitle/toctitle for mark_new_chapters. Broken in chapter metadata
- revamp.
-- Fix tocpage links and correct index04 vs index, issue #320.
-- Refactor chapter internals for additional site-specific metadata per
- chapter.
-- Fix base_xenforo_list for AH & QQ prefered domains.
-- base_xenforoforum: Adding date, words & kwords per chapter metadata
- (SB/SB/QQ).
-- Whitespace clean up in code (#316) - thanks mcepl
-- Add alternate domains for SB, SV & QQ xenforo adapters.
-- base_xenforoforum: Sum threadmark word counts into numWords(when present).
- INI option use_threadmark_wordcounts defaults to true.
-- Add ignore_chapter_url_list feature.
-- adapter_trekfanfictionnet: don't set numWords to *character* count.
-- Add adapter_harrypotterfanfictioncom for new version of returned
- harrypotterfanfiction.com.
-- Add adapter for http://wuxiaworld.co/ (#315) - Thanks cryzed
+Version 4.3.0 - 2021-05-30
+- quotev.com: use_cloudscraper:true by default.
+- Update translations
+- adapter_bdsmlibrarycom: Set author Anonymous when author not found instead
+ of sys.exit(). Closes #696
+- Fix XF authorUrl and author_avatar_cover feature. Closes #695
+- Catch exceptions in word count.
+- Add CLI --color option for warns and fails. Closes #692
+- Report browser cache load fail as such.
-Version 2.27.0 - 03 Jul 2018
-- Change adapter_storiesonlinenet to https (and derived finestories) - thanks
- davidfor.
-- Yet more site change for adapter_webnovelcom
-- Add status states Paused & Cancelled to adapter_fanfiktionde as well as site
- specific native_status.
-- adapter_webnovelcom: ignore 'ad-walled' chapters--the ad-wall bypass code
- stopped working, but isn't yet removed.
-- Calibre Plugin: Remove ebook formats before update, overwrite or unnew so
- that the previouis version ends up in trash instead of just copied over.
-- Add adapter_classes metadata for developer testing.
-- Revert archive.skyehawke.com back https -> http.
-- Remove replace_br_with_p sentinels in desc HTML before giving to Calibre.
-- Fix for author in adapter_lcfanficcom
-- Fix for adapter_inkbunnynet author search.
-- base_efiction: use getProtocol for images too.
-- Change all sites that will work with https to use it all the time.
-- Remove fanfiction.mugglenet.com -- mugglenet.com is there, but no fanfic
- section anymore.
-- adapter_adultfanfictionorg used urllib2 exceptions without importing it.
-- Updates for site changes for adapter_gravitytalescom.
-- Fix author for adapter_inkbunnynet.
-- Site update fixes for adapter_inkbunnynet, thanks GComyn.
-- Fixes for adapter_webnovelcom for site changes.
-- Add status to webnovelcom (#306) - Thanks, rikkitp
+Version 4.2.0 - 30 Apr 2021
+- Add New Site: novelfull.com (#688 & #689) - Thanks, AlexRiina!
+- Need to set logger.setLevel() again with import changes to see debugs in
+ plugin.
+- import changes for arch linux system plugins - As submitted by eli-schwartz
+- Remove site: fictionpad.com, completely different site, looks like generic
+ parked?
+- Remove site: www.thundercatsfans.org, no longer efiction, now static pages
+ and PDFs
+- Remove site: www.thepetulantpoetess.com, no longer efiction, URLs like OTW
+ but different
+- Remove site: www.potterfics.com, "Potterfics.com has closed its doors
+ forever"
+- Remove site: fanfic.castletv.net, DNS there, no server, last successful
+ 2018-10-21
+- Remove site: deandamage.com, site there, efiction broken, last successful
+ 2018-12-04
+- Remove site: www.deepinmysoul.net, moved to deepinmysoul.nl and changed
+ software--not eFiction anymore, <100 stories, all old
+- Include code for nsapa_proxy for dealing with Captchas (by nsapa -- coming
+ soon!)
+- Some other import cleanup.
+- Updates from cloudscraper 1.2.58
+- Use newer Calibre image processing, add JPG quality setting - thanks, Malloc
+ Voidstar
+- Add use_cloudscraper:true under [www.ficbook.net] to defaults.ini
+- Fix for adapter_literotica story URL oddities. Again.
+- Fix for site change: adapter_fictionmaniatv
+- Get storyId for sugarquillnet and siyecouk from the parsed query string.
+ From mcepl
+- Fix for adapter_literotica changing URLs on author page yet again.
+- Add [harrypotterfanfiction.com] slow_down_sleep_time:1 -- Site blocking fast
+ downloads.