summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2018-09-07 17:51:58 -0400
committerEli Schwartz2018-09-07 17:51:58 -0400
commit6071a4c3729cfaf404a48bc44131d5f5951b8c2b (patch)
tree38ca2f98f282ed7ee9bbe87c1188261e1f3a48d4
parent52821c7f96cb50ee12b3e66b013b97c74173d4f6 (diff)
downloadaur-6071a4c3729cfaf404a48bc44131d5f5951b8c2b.tar.gz
upgpkg: fanficfare-git 2.28.0.r167.g09fd06cd-2
Since the python3 port is merged to master, now is a good time to update the dependencies. Yay!
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3334b0b9fe2..11f24b2f996b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = fanficfare-git
pkgdesc = A tool for downloading fanfiction to eBook formats
- pkgver = 2.28.0.r0.g1194be86
- pkgrel = 1
+ pkgver = 2.28.0.r167.g09fd06cd
+ pkgrel = 2
url = https://github.com/JimmXinu/FanFicFare
arch = any
license = Apache
makedepends = git
- depends = python2
- depends = python2-beautifulsoup4
- depends = python2-chardet
- depends = python2-html5lib
- depends = python2-html2text
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-chardet
+ depends = python-html5lib
+ depends = python-html2text
provides = fanficfare
conflicts = fanficfare
source = git+https://github.com/JimmXinu/FanFicFare.git
diff --git a/PKGBUILD b/PKGBUILD
index 7b4c06fac582..1fa9c043d7a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=FanFicFare
pkgname=fanficfare-git
-pkgver=2.28.0.r0.g1194be86
-pkgrel=1
+pkgver=2.28.0.r167.g09fd06cd
+pkgrel=2
pkgdesc="A tool for downloading fanfiction to eBook formats"
arch=('any')
url="https://github.com/JimmXinu/${_pkgname}"
license=('Apache')
-depends=('python2' 'python2-beautifulsoup4' 'python2-chardet' 'python2-html5lib'
- 'python2-html2text')
+depends=('python' 'python-beautifulsoup4' 'python-chardet' 'python-html5lib'
+ 'python-html2text')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -25,16 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- python2 setup.py build
+ python setup.py build
- if [[ -x /usr/bin/calibre-customize ]]; then
+ if command -v calibre-customize > /dev/null; then
msg2 "Creating and installing FanFicFare calibre plugin..."
- python2 makeplugin.py
+ python makeplugin.py
calibre-customize -a FanFicFare.zip || true
fi
}
package() {
cd "${srcdir}/${_pkgname}"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}