summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortsonntig2017-06-29 17:09:16 +0200
committertsonntig2017-06-29 17:09:16 +0200
commitf419a0b82b8add33b79e4f94c4c464681810bfde (patch)
tree48ab2ad1341a77642f49390b3ac7fadb3f3fd78b
downloadaur-f419a0b82b8add33b79e4f94c4c464681810bfde.tar.gz
first upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4f76cd1d463
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fanicontrol
+ pkgdesc = a new way controling your fans
+ pkgver = 0.28
+ pkgrel = 1
+ url = https://github.com/tsonntig/Fanicontrol
+ arch = any
+ license = GPL2 only
+ makedepends = git
+ depends = python3
+ source = git+https://github.com/tsonntig/Fanicontrol.git
+ md5sums = SKIP
+
+pkgname = fanicontrol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4adbe8780d29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: tsonntig
+
+pkgname=fanicontrol
+pkgver=0.28
+pkgrel=1
+pkgdesc="a new way controling your fans"
+arch=('any')
+url="https://github.com/tsonntig/Fanicontrol"
+license=('GPL2 only')
+depends=(python3)
+makedepends=('git')
+source=('git+https://github.com/tsonntig/Fanicontrol.git')
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/Fanicontrol"
+ install -Dm644 'arch/fanicontrol.service' "$pkgdir/usr/lib/systemd/system/fanicontrol.service"
+ python arch/setup.py install --root="$pkgdir/" --optimize=1
+}
+
+
+