summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeej Jorgensen2015-07-28 16:09:49 -0700
committerBeej Jorgensen2015-07-28 16:09:49 -0700
commite33f31ea845cb262ebe14753333576b258850e7b (patch)
treed6181bc33fdc2433d6aae6c3552b4a4eb38372ab
downloadaur-e33f31ea845cb262ebe14753333576b258850e7b.tar.gz
Version 2.2.0-2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3820da8e7307
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fann
+ pkgdesc = Fast artificial neural network library
+ pkgver = 2.2.0
+ pkgrel = 2
+ url = http://leenissen.dk/fann/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = cmake
+ source = http://downloads.sourceforge.net/sourceforge/fann/FANN-2.2.0-Source.zip
+ md5sums = 292d914684c9eab1d84eb1f59b0fbf69
+
+pkgname = fann
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08ecaec4ee32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Andreas Hauser <andy-aur@splashground.de>
+# Maintainer: Beej Jorgensen <beej@beej.us>
+pkgname=fann
+pkgver=2.2.0
+pkgrel=2
+pkgdesc="Fast artificial neural network library"
+url="http://leenissen.dk/fann/"
+arch=('i686' 'x86_64')
+license=('LGPL2.1')
+makedepends=('cmake')
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/FANN-$pkgver-Source.zip")
+md5sums=('292d914684c9eab1d84eb1f59b0fbf69')
+
+build() {
+ cd $srcdir/FANN-${pkgver}-Source
+ cmake -D CMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $srcdir/FANN-${pkgver}-Source
+ make DESTDIR=$pkgdir install
+}