summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroshaboy2019-12-11 18:18:45 +0200
committeroshaboy2019-12-11 18:18:45 +0200
commit06f85edc2af53c18cbfeeea3dc00f8a8bfe7ec92 (patch)
tree06ca0ed41e87b358a1a78afa7ea0b944798afd57
downloadaur-06f85edc2af53c18cbfeeea3dc00f8a8bfe7ec92.tar.gz
Initial Commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..596c11ce8fd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fanwor
+ pkgdesc = An adventure game with heavy inspiration from The Legend of Zelda
+ pkgver = 1
+ pkgrel = 1
+ url = http://fanwor.tuxfamily.org/
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPLv2
+ makedepends = gcc
+ depends = sdl2
+ depends = libpng
+ depends = glibc
+ depends = zlib
+ depends = sdl2_mixer
+ source = git+git://git.tuxfamily.org/gitroot/fanwor/fanwor.git
+ sha256sums = SKIP
+
+pkgname = fanwor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c24db561c50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer: oshaboy <noamgilor{at}protonmail{dot}com>
+
+pkgname=fanwor
+pkgver=1
+pkgrel=1
+pkgdesc="An adventure game with heavy inspiration from The Legend of Zelda"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="http://fanwor.tuxfamily.org/"
+license=('GPLv2')
+depends=(sdl2 libpng glibc zlib sdl2_mixer)
+optdepends=()
+makedepends=(gcc)
+source=("git+git://git.tuxfamily.org/gitroot/fanwor/fanwor.git")
+sha256sums=('SKIP')
+build() {
+ cd fanwor
+ make
+ echo -e $run_script >| ${srcdir}/fanwor.sh
+}
+run_script='cd /opt/fanwor && ./fanwor'
+package(){
+ mkdir ${pkgdir}/opt ${pkgdir}/opt/fanwor ${pkgdir}/usr ${pkgdir}/usr/bin/
+ cp -r ${srcdir}/fanwor/* ${pkgdir}/opt/fanwor
+ install -Dm755 ${srcdir}/fanwor.sh ${pkgdir}/usr/bin/fanwor
+ chmod 755 ${pkgdir}/opt/fanwor
+
+}