summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2017-07-09 20:08:53 -0400
committerZeke Sonxx2017-07-09 20:08:53 -0400
commit391d34974f9f7aa8e8b650209f2bdd7ed77d3b20 (patch)
tree28fac91b2794037d362584276ca32c5d9581ea16
downloadaur-391d34974f9f7aa8e8b650209f2bdd7ed77d3b20.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..310c17f80451
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fargo-git
+ pkgdesc = Removes unseeable and ghost alpha from PNG images.
+ pkgver = r7.f58f58f
+ pkgrel = 1
+ url = https://github.com/DaemonLee/fargo
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = perl
+ depends = imagemagick
+ provides = fargo-git
+ conflicts = fargo-git
+ source = fargo::git+https://github.com/DaemonLee/fargo
+ md5sums = SKIP
+
+pkgname = fargo-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5805e54b715c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+fargo/
+pkg/
+src/
+fargo-git*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30f096a1bd8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# shellcheck shell=bash
+# shellcheck disable=SC2034,SC2148,SC2154
+# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
+pkgname=fargo-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r7.f58f58f
+pkgrel=1
+pkgdesc="Removes unseeable and ghost alpha from PNG images."
+arch=('i686' 'x86_64')
+url="https://github.com/DaemonLee/fargo"
+license=('GPL3')
+groups=()
+depends=('imagemagick')
+makedepends=('git' 'perl')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+replaces=()
+backup=()
+options=()
+install=
+source=('fargo::git+https://github.com/DaemonLee/fargo')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}" || exit
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}" || exit
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}" || exit
+ make DESTDIR="$pkgdir/" install
+}