summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerass El Hafidi2023-01-06 16:47:24 +0100
committerFerass El Hafidi2023-01-06 16:47:24 +0100
commit05e6d3597a24efd53469f22e939f3ab87cb685b1 (patch)
tree4d127bd7cda07febb1ab75d1e9bb402c67f1be75
downloadaur-05e6d3597a24efd53469f22e939f3ab87cb685b1.tar.gz
Initial commit
Signed-off-by: Ferass El Hafidi <vitali64pmemail@protonmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe3088e01e64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fasesbox-git
+ pkgdesc = Simple utilities for a fully functionnal UNIX-like system.
+ pkgver = r247.25f1754
+ pkgrel = 1
+ url = https://git.vitali64.duckdns.org/utils/fases.git
+ arch = any
+ license = GPL3,
+ license = custom:3BSD,
+ license = custom:FreeBSDDocumentationLicense
+ makedepends = git
+ provides = fasesbox-git
+ conflicts = fasesbox-git
+ source = /fases::git+https://git.vitali64.duckdns.org/git/utils/fases.git
+ md5sums = SKIP
+
+pkgname = fasesbox-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c58bd6021318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# fases Arch Linux and Debian GNU/Linux packages
+# Maintainer: Ferass EL HAFIDI <vitali64pmemail@protonmail.com>
+pkgname=fasesbox-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=247.25f1754
+pkgrel=1
+pkgdesc="Simple utilities for a fully functionnal UNIX-like system."
+arch=('any')
+url="https://git.vitali64.duckdns.org/utils/fases.git"
+license=('GPL3', 'custom:3BSD', 'custom:FreeBSDDocumentationLicense')
+groups=()
+depends=()
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+replaces=()
+backup=()
+options=()
+install=
+source=("$srcdir/${pkgname%box-git}"::'git+https://git.vitali64.duckdns.org/git/utils/fases.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%box-git}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%box-git}"
+ make prepbox genbox box
+}
+
+package() {
+ cd "$srcdir/${pkgname%box-git}"
+ make DESTDIR="$pkgdir/" install-box
+}