summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXIE Yuheng2015-07-21 22:47:02 +0800
committerXIE Yuheng2015-07-21 22:47:02 +0800
commitea6287586e685579de0628420f0ddefce0f41026 (patch)
tree76e883decad1ac00f5a721636b7489a885d2042b
downloadaur-ea6287586e685579de0628420f0ddefce0f41026.tar.gz
1st ci
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--makefile43
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43bd12a11162
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fasm-linux-git
+ pkgdesc = fast assembler for x86 and x86-64 [github mirror of linux version]
+ pkgver = 1.71.39
+ pkgrel = 3
+ url = http://flatassembler.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ provides = fasm
+ conflicts = fasm
+ source = git+https://github.com/the-little-language-designer/fasm-linux.git
+ md5sums = SKIP
+
+pkgname = fasm-linux-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff1902291457
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: XIE Yuheng <xyheme@gmail.com>
+
+pkgname=fasm-linux-git
+pkgver=1.71.39
+pkgrel=3
+pkgdesc="fast assembler for x86 and x86-64 [github mirror of linux version]"
+url="http://flatassembler.net/"
+makedepends=('git')
+license=('custom')
+arch=('i686' 'x86_64')
+source=('git+https://github.com/the-little-language-designer/fasm-linux.git')
+provides=('fasm')
+conflicts=('fasm')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/fasm-linux"
+ make
+}
+
+package() {
+ cd "$srcdir/fasm-linux"
+ make PREFIX="$pkgdir/usr" install
+}
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..8ea4068582f7
--- /dev/null
+++ b/makefile
@@ -0,0 +1,43 @@
+.ONESHELL:
+
+DIR=fasm-linux
+PKG=fasm-linux-git
+
+all:
+ @
+ make build &&\
+ make ball
+build:
+ @
+ makepkg -sf
+
+ball:
+ @
+ mkaurball -f
+
+upload:
+ @
+ aurupload $(PKG)-*.src.tar.gz
+
+install:
+ @
+ pacman -U $(PKG)-*.pkg.tar.xz
+
+clean*~:
+ @
+ rm -f *~ */*~ */*/*~ */*/*/*~ */*/*/*/*~ */*/*/*/*/*~
+
+clean*.bin:
+ @
+ rm -f *.bin */*.bin */*/*.bin */*/*/*.bin */*/*/*/*.bin */*/*/*/*/*.bin
+
+clean:
+ @
+ make clean*~
+ make clean*.bin
+ rm $(PKG)-*.pkg.tar.xz
+ rm $(PKG)-*.src.tar.gz
+ rm -rf src
+ rm -rf pkg
+ rm -rf $(DIR)
+ echo -e "\e[33;1m [ok] clean directory \e[0m"