summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRelwi2022-08-05 15:19:02 +0200
committerRelwi2022-08-05 15:19:02 +0200
commit95ddd0a0a085bc46b6fa032cd17cc7b4bfde140f (patch)
tree4418d8b0ee1a09574a3b7ed62874bbf192833dd3
parentdc3aaf5542198a2b994f1122a73ee7027f83e41f (diff)
downloadaur-95ddd0a0a085bc46b6fa032cd17cc7b4bfde140f.tar.gz
Changes by FabioLolix
It organizes and improves the PKGBUILD, thanks!
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 824a89e3e561..974e5acffffc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = fast-discord-git
pkgdesc = A new Discord client made in C++ and Qt
pkgver = r213.17e593e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/EnyoYoen/Fast-Discord
- arch = any
+ arch = x86_64
+ arch = arm
+ arch = aarch64
license = MIT
makedepends = cmake
- depends = git
- depends = pacman
+ makedepends = git
depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-websockets
depends = opus
depends = libsodium
- depends = qt5-websockets
- depends = qt5-multimedia
source = fast-discord-git::git+https://github.com/EnyoYoen/Fast-Discord
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = fast-discord-git
diff --git a/PKGBUILD b/PKGBUILD
index b93d4e2951f7..baafbc64cac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Relwi <theofficialdork@hotmail.com>
pkgname=fast-discord-git
pkgver=r213.17e593e
-pkgrel=1
+pkgrel=2
pkgdesc='A new Discord client made in C++ and Qt'
url='https://github.com/EnyoYoen/Fast-Discord'
source=("${pkgname}::git+https://github.com/EnyoYoen/Fast-Discord")
-arch=('any')
-license=('MIT')
-makedepends=('cmake')
-depends=('git' 'pacman' 'qt5-base' 'opus' 'libsodium' 'qt5-websockets' 'qt5-multimedia')
-md5sums=('SKIP')
+arch=(x86_64 arm aarch64)
+license=(MIT)
+depends=(qt5-base qt5-multimedia qt5-websockets opus libsodium)
+makedepends=(cmake git)
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
@@ -29,4 +29,5 @@ package() {
install -Dm755 bin/Fast-Discord "${pkgdir}/usr/bin/fast-discord"
install -Dm644 "resources/com.enyoyoen.fast-discord.desktop" "$pkgdir/usr/share/applications/com.enyoyoen.fast-discord.desktop"
install -Dm644 "doc/images/Fast-Discord-Logo.png" "$pkgdir/usr/share/pixmaps/fast-discord.png"
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}