summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRelwi2022-08-05 11:33:47 +0200
committerRelwi2022-08-05 11:33:47 +0200
commitfe8f097208ec1153f857fa67cac5d639c1f8bf62 (patch)
treee6e2b7c0cd823fd942e9a412d84b9bff89ce3dc6
downloadaur-fe8f097208ec1153f857fa67cac5d639c1f8bf62.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf0813eee00c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fast-discord-git
+ pkgdesc = A new Discord client made in C++ and Qt
+ pkgver = 3c6ce0c46bd80c20f32b340da3ea68af32e36304
+ pkgrel = 1
+ url = https://github.com/EnyoYoen/Fast-Discord
+ arch = any
+ license = MIT
+ makedepends = cmake
+ depends = git
+ depends = pacman
+ depends = qt5-base
+ depends = opus
+ depends = libsodium
+ source = fast-discord-git::git+https://github.com/EnyoYoen/Fast-Discord
+ md5sums = SKIP
+
+pkgname = fast-discord-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcd0dad81048
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Relwi <theofficialdork@hotmail.com>
+pkgname=fast-discord-git
+pkgver=3c6ce0c46bd80c20f32b340da3ea68af32e36304
+pkgrel=1
+pkgdesc='A new Discord client made in C++ and Qt'
+url='https://github.com/EnyoYoen/Fast-Discord'
+source=("${pkgname}::git+https://github.com/EnyoYoen/Fast-Discord")
+arch=('any')
+license=('MIT')
+makedepends=('cmake')
+depends=('git' 'pacman' 'qt5-base' 'opus' 'libsodium')
+md5sums=('SKIP')
+
+build () {
+ cd "$pkgname/bin"
+
+ cmake ..
+ cmake --build .
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 bin/Fast-Discord "${pkgdir}/usr/bin/fast-discord"
+ #install -Dm644 "resources/com.enyoyoen.fast-discord.desktop" "$pkgdir/usr/share/applications/com.enyoyoen.fast-discord.desktop"
+ #install -Dm644 "doc/images/Fast-Discord-Logo.png" "$pkgdir/usr/share/pixmaps/fast-discord.png"
+}