summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortty20992019-06-23 13:34:08 +0800
committertty20992019-06-23 13:34:08 +0800
commit8295328b9ac4f85fa0279189b04211683b80526c (patch)
tree63e6849b5f469a35eef9e8f3fa0d57eef03ac911
downloadaur-8295328b9ac4f85fa0279189b04211683b80526c.tar.gz
fastcdr
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7393827af4be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fastcdr
+ pkgdesc = eProsima FastCDR is a C++ library that provides two serialization mechanisms. One is the standard CDR serialization mechanism, while the other is a faster implementation that modifies the standard.
+ pkgver = 1.0.9
+ pkgrel = 1
+ url = https://www.eprosima.com
+ arch = any
+ license = Apache2.0
+ makedepends = cmake
+ source = https://github.com/eProsima/Fast-CDR/archive/v1.0.9.tar.gz
+ sha256sums = 02a89dda8fd8db3ec2e367c13f11d84b27bf35d6b10fa2c61045a74ea6da9ddb
+
+pkgname = fastcdr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71bdecaa0846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tong Chunli (tty2099@gmail.com)
+
+pkgname=fastcdr
+_pkgnm=Fast-CDR
+pkgver=1.0.9
+pkgrel=1
+pkgdesc="eProsima FastCDR is a C++ library that provides two serialization mechanisms. One is the standard CDR serialization mechanism, while the other is a faster implementation that modifies the standard."
+arch=('any')
+url="https://www.eprosima.com"
+license=('Apache2.0')
+depends=()
+makedepends=('cmake')
+source=(https://github.com/eProsima/Fast-CDR/archive/v${pkgver}.tar.gz)
+sha256sums=('02a89dda8fd8db3ec2e367c13f11d84b27bf35d6b10fa2c61045a74ea6da9ddb')
+
+
+package(){
+ cd "$srcdir"
+ rm -rf build
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ../$_pkgnm-$pkgver
+ make
+ make DESTDIR=$pkgdir install
+}
+