summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-02-21 08:31:34 -0700
committerMark Wagie2023-02-21 08:31:34 -0700
commit40abe06400a1823a173d30fedf17e4660416cbf5 (patch)
treef64d485b6c4d48667c1ed8f23748a3e6c3a00403
parent9ab58c86ac55e0d38f3e4f5e8d35173c0701b6d4 (diff)
downloadaur-40abe06400a1823a173d30fedf17e4660416cbf5.tar.gz
1.10.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff73a900f9e..97d8c04359b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fastfetch
pkgdesc = Like Neofetch, but much faster because written in C
- pkgver = 1.9.1
- pkgrel = 4
+ pkgver = 1.10.1
+ pkgrel = 1
url = https://github.com/LinusDierheimer/fastfetch
arch = x86_64
arch = aarch64
@@ -13,6 +13,7 @@ pkgbase = fastfetch
makedepends = dconf
makedepends = imagemagick
makedepends = libnm
+ makedepends = libpulse
makedepends = libxcb
makedepends = libxrandr
makedepends = mesa
@@ -26,11 +27,12 @@ pkgbase = fastfetch
makedepends = zlib
depends = gcc-libs
optdepends = chafa: Image output as ascii art
- optdepends = dbus: Needed for detecting current media player and song
+ optdepends = dbus: Bluetooth, Player & Media detection
optdepends = dconf: Needed for values that are only stored in DConf + Fallback for GSettings
optdepends = glib2: Output for values that are only stored in GSettings
optdepends = imagemagick: Image output using sixel or kitty graphics protocol
optdepends = libnm: Used for Wifi detection
+ optdepends = libpulse: Used for Sound detection
optdepends = mesa: Needed by the OpenGL module for gl context creation.
optdepends = libxrandr: Multi monitor support
optdepends = ocl-icd: OpenCL module
@@ -39,7 +41,7 @@ pkgbase = fastfetch
optdepends = xfconf: Needed for XFWM theme and XFCE Terminal font
optdepends = zlib: Faster image output when using kitty graphics protocol
backup = etc/fastfetch/config.conf
- source = fastfetch-1.9.1.tar.gz::https://github.com/LinusDierheimer/fastfetch/archive/refs/tags/1.9.1.tar.gz
- sha256sums = 0b6d31bc213282b26a7c2fc9706d41e1669a7ea8875154ba6aed1ba428c92b3d
+ source = fastfetch-1.10.1.tar.gz::https://github.com/LinusDierheimer/fastfetch/archive/refs/tags/1.10.1.tar.gz
+ sha256sums = 3741521d265ac948cbf0fe3a098b3296d1b18d16f3a159fd6669794ef720525b
pkgname = fastfetch
diff --git a/PKGBUILD b/PKGBUILD
index d3452075ecac..538316471bd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=fastfetch
-pkgver=1.9.1
-pkgrel=4
+pkgver=1.10.1
+pkgrel=1
pkgdesc="Like Neofetch, but much faster because written in C"
arch=('x86_64' 'aarch64' 'riscv64')
url="https://github.com/LinusDierheimer/fastfetch"
license=('MIT')
depends=('gcc-libs')
-makedepends=('chafa' 'cmake' 'dbus' 'dconf' 'imagemagick' 'libnm' 'libxcb'
+makedepends=('chafa' 'cmake' 'dbus' 'dconf' 'imagemagick' 'libnm' 'libpulse' 'libxcb'
'libxrandr' 'mesa' 'ocl-icd' 'opencl-headers' 'pciutils'
'vulkan-headers' 'vulkan-icd-loader' 'wayland' 'xfconf' 'zlib')
optdepends=(
'chafa: Image output as ascii art'
- 'dbus: Needed for detecting current media player and song'
+ 'dbus: Bluetooth, Player & Media detection'
'dconf: Needed for values that are only stored in DConf + Fallback for GSettings'
'glib2: Output for values that are only stored in GSettings'
'imagemagick: Image output using sixel or kitty graphics protocol'
'libnm: Used for Wifi detection'
+ 'libpulse: Used for Sound detection'
'mesa: Needed by the OpenGL module for gl context creation.'
'libxrandr: Multi monitor support'
'ocl-icd: OpenCL module'
@@ -27,7 +28,7 @@ optdepends=(
)
backup=("etc/$pkgname/config.conf")
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('0b6d31bc213282b26a7c2fc9706d41e1669a7ea8875154ba6aed1ba428c92b3d')
+sha256sums=('3741521d265ac948cbf0fe3a098b3296d1b18d16f3a159fd6669794ef720525b')
build() {
cmake -B build -S "$pkgname-$pkgver" \