summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2021-11-13 18:31:30 +0100
committerLinus Dierheimer2021-11-13 18:31:30 +0100
commit262c53517db2d0da4b37938b8586338aa1cb950c (patch)
tree93e53074ea845b79f78d61d56abfab2b34f4db68
parent32143ef4c3c07a221e55b0cbf76d3aae31a4c244 (diff)
downloadaur-262c53517db2d0da4b37938b8586338aa1cb950c.tar.gz
Added vulkan
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e5ec30d73f7..e8693d709d13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fastfetch-git
pkgdesc = Like neofetch, but much faster because written in c
- pkgver = r460.0c7a415
+ pkgver = r473.dff3ca5
pkgrel = 1
url = https://github.com/LinusDierheimer/fastfetch
arch = any
@@ -8,11 +8,14 @@ pkgbase = fastfetch-git
makedepends = git
makedepends = cmake
makedepends = pciutils
+ makedepends = vulkan-headers
+ makedepends = vulkan-icd-loader
makedepends = libxrandr
makedepends = dconf
makedepends = wayland
makedepends = xfconf
optdepends = pciutils: GPU output
+ optdepends = vulkan-icd-loader: GPU fallback
optdepends = libx11: Basic resolution output
optdepends = libxrandr: Multi monitor and refresh rate support for resolution output
optdepends = wayland: Native wayland support for resolution output
diff --git a/PKGBUILD b/PKGBUILD
index 843e13efeb55..08d2c171b748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=r460.0c7a415
+pkgver=r473.dff3ca5
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("any")
@@ -12,6 +12,8 @@ makedepends=(
"git"
"cmake"
"pciutils"
+ "vulkan-headers"
+ "vulkan-icd-loader"
"libxrandr" # Depends on libX11, which headers are also needed
"dconf" # Depends on glib2, which headers are also needed
"wayland"
@@ -20,6 +22,7 @@ makedepends=(
)
optdepends=(
"pciutils: GPU output"
+ "vulkan-icd-loader: GPU fallback"
"libx11: Basic resolution output"
"libxrandr: Multi monitor and refresh rate support for resolution output"
"wayland: Native wayland support for resolution output"