summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2022-03-08 12:06:53 +0100
committerLinus Dierheimer2022-03-08 12:06:53 +0100
commit27dbdd90403b7581c450b509c994435ebbb16489 (patch)
tree550ffce7bdf778ecd2b568606296f7b82766425c
parentceeec35245b0039dc4667cd823683d6ee494557f (diff)
downloadaur-27dbdd90403b7581c450b509c994435ebbb16489.tar.gz
Use CMake for installing
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70b9fbad3ea3..207bc5337840 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fastfetch-git
pkgdesc = Like neofetch, but much faster because written in c
- pkgver = r587.cfb5d20
+ pkgver = r610.2310162
pkgrel = 1
url = https://github.com/LinusDierheimer/fastfetch
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2a2e2b59951c..328fdf98a8ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=r587.cfb5d20
+pkgver=r610.2310162
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("x86_64" "i686" "pentium4" "armv5" "armv6h" "armv7h" "aarch64")
@@ -53,22 +53,11 @@ pkgver() {
build()
{
cd "${srcdir}/fastfetch"
- mkdir -p build/
- cd build/
- cmake ..
+ cmake .
cmake --build . --target fastfetch # don't build flashfetch, as it is meant to be configured at compile time. So it doesn't make sense to pre build it.
}
package() {
cd "${srcdir}/fastfetch"
-
- install -D "build/fastfetch" "${pkgdir}/usr/bin/fastfetch"
- install -D "completions/bash" "${pkgdir}/usr/share/bash-completion/completions/fastfetch"
-
- install -Dd "${pkgdir}/usr/share/fastfetch/presets/"
- for file in presets/*; do
- install -D "$file" "${pkgdir}/usr/share/fastfetch/presets/"
- done
-
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cmake --install . --prefix "${pkgdir}/usr"
}