summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2021-06-15 13:20:22 +0200
committerLinus Dierheimer2021-06-15 13:20:22 +0200
commit6c63df14129f5929483749e0fa148da1e0e9ee37 (patch)
tree5691b18fb25d38986ec1cf4998d50de714a9a25f
parent4fced8640b83f2b2fd0d07594b64485d212dedc4 (diff)
downloadaur-6c63df14129f5929483749e0fa148da1e0e9ee37.tar.gz
added provides and conflicts array
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8363502f9ef0..a084f4566776 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = fastfetch-git
pkgdesc = Like neofetch, but much faster because written in c
- pkgver = r339.580ad45
+ pkgver = r367.409b1f2
pkgrel = 1
url = https://github.com/LinusDierheimer/fastfetch
arch = any
license = MIT
+ makedepends = git
makedepends = cmake
makedepends = pciutils
makedepends = libxrandr
@@ -19,7 +20,12 @@ pkgbase = fastfetch-git
optdepends = dconf: Output for values that are only stored in DConf
optdepends = xfconf: XFWM theme + xfce-terminal font
optdepends = sqlite: rpm package count
- provides = flashfetch=r339.580ad45
+ provides = fastfetch
+ provides = fastfetch-garuda
+ provides = flashfetch
+ conflicts = fastfetch
+ conflicts = fastfetch-garuda
+ conflicts = flashfetch
source = git+https://github.com/LinusDierheimer/fastfetch.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aaa2d799ac9c..921fa1d8656a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=r339.580ad45
+pkgver=r367.409b1f2
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("any")
@@ -9,6 +9,7 @@ url="https://github.com/LinusDierheimer/fastfetch"
license=("MIT")
depends=()
makedepends=(
+ "git"
"cmake"
"pciutils"
"libxrandr" # Depends on libX11, which headers are also needed
@@ -26,7 +27,13 @@ optdepends=(
"xfconf: XFWM theme + xfce-terminal font"
"sqlite: rpm package count"
)
-provides=("flashfetch=${pkgver}")
+_provides_and_conflicts=(
+ "fastfetch"
+ "fastfetch-garuda"
+ "flashfetch"
+)
+provides=("${_provides_and_conflicts[@]}")
+conflicts=("${_provides_and_conflicts[@]}")
source=("git+https://github.com/LinusDierheimer/fastfetch.git")
sha256sums=("SKIP")