summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2023-01-24 10:52:31 +0100
committerLinus Dierheimer2023-01-24 10:52:31 +0100
commit99782c79c828422fb5fe2acd50ef8ff02b2658ab (patch)
treea852b8910c4c0a4e77909973290f9040b2476934
parent546e156c41b3cd7e312de6d13914db63703bdf6c (diff)
downloadaur-99782c79c828422fb5fe2acd50ef8ff02b2658ab.tar.gz
Add check function & update optdeps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9334db91f5fc..8db84419617c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fastfetch-git
pkgdesc = Like neofetch, but much faster because written in c
- pkgver = 1.8.2.r153.ge0b2db1
+ pkgver = 1.9.1.r4.gd718cc9
pkgrel = 1
url = https://github.com/LinusDierheimer/fastfetch
arch = x86_64
@@ -38,7 +38,7 @@ pkgbase = fastfetch-git
optdepends = libxrandr: Improved X11 support (resolution + multi monitor)
optdepends = glib2: Output for values that are only stored in GSettings
optdepends = dconf: Output for values that are only stored in DConf
- optdepends = dbus: Media player and song output
+ optdepends = dbus: Bluetooth, Media & Player modules
optdepends = imagemagick: Image output using sixel or kitty graphics protocol
optdepends = chafa: Image output as ascii art
optdepends = zlib: Faster image output when using kitty graphics protocol
diff --git a/PKGBUILD b/PKGBUILD
index a0d250dffdd1..0d19f9a3b137 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=1.8.2.r153.ge0b2db1
+pkgver=1.9.1.r4.gd718cc9
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("x86_64" "i686" "pentium4" "armv5" "armv6h" "armv7h" "aarch64")
@@ -44,7 +44,7 @@ optdepends=(
"libxrandr: Improved X11 support (resolution + multi monitor)"
"glib2: Output for values that are only stored in GSettings"
"dconf: Output for values that are only stored in DConf"
- "dbus: Media player and song output"
+ "dbus: Bluetooth, Media & Player modules"
"imagemagick: Image output using sixel or kitty graphics protocol"
"chafa: Image output as ascii art"
"zlib: Faster image output when using kitty graphics protocol"
@@ -82,7 +82,9 @@ build() {
cmake \
-B "${_build_dir}" \
-S "${_src_dir}" \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS='ON' \
-DENABLE_SQLITE3=OFF \
-DENABLE_RPM=OFF \
-DENABLE_IMAGEMAGICK6=OFF \
@@ -93,6 +95,10 @@ build() {
--build "${_build_dir}"
}
+check() {
+ ctest --test-dir "${_build_dir}" --output-on-failure
+}
+
package() {
DESTDIR="${pkgdir}" \
cmake \