summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2022-04-06 14:20:31 +0200
committerLinus Dierheimer2022-04-06 14:20:31 +0200
commita6210a1681a2985678d20cf6c3db53ae8a8c0399 (patch)
tree96d009ee3da71ef4d9bc4dabe39318eccb65de74
parent7a9a5005dd0dd797f759db441b8ba324eb2f3369 (diff)
downloadaur-a6210a1681a2985678d20cf6c3db53ae8a8c0399.tar.gz
Only support imagemagick 7 for now
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bed647c761c8..cf1440d5bdf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=1.2.0.r2.g24a48c1
+pkgver=1.2.3.r5.g5346104
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("x86_64" "i686" "pentium4" "armv5" "armv6h" "armv7h" "aarch64")
@@ -19,6 +19,7 @@ makedepends=(
"libxcb"
"libxrandr" # Depends on libX11, which headers are also needed
"dconf" # Depends on glib2, which headers are also needed
+ "imagemagick"
"dbus"
"xfconf"
# "rpm-tools"
@@ -33,6 +34,7 @@ optdepends=(
"glib2: Output for values that are only stored in GSettings"
"dconf: Output for values that are only stored in DConf"
"dbus: Media player and song output"
+ "imagemagick: Image output using sixel"
"xfconf: XFWM theme + xfce-terminal font"
# "rpm-tools: rpm package count"
)
@@ -56,7 +58,7 @@ pkgver() {
build() {
cmake -B "${_build_dir}" -S "${_src_dir}" -Wno-dev
- cmake --build "${_build_dir}" --target fastfetch # don't build flashfetch, as it is meant to be configured at compile time. So it doesn't make sense to pre build it.
+ cmake --build "${_build_dir}" --target fastfetch --target flashfetch
}
package() {