summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2022-03-23 14:21:22 +0100
committerLinus Dierheimer2022-03-23 14:21:22 +0100
commitd7ba439ac99ddfc64b47f046c1ff4ddfcdc9334a (patch)
tree27512a6460eb09d83f73f3e4a28529eee89fa8a4
parent27dbdd90403b7581c450b509c994435ebbb16489 (diff)
downloadaur-d7ba439ac99ddfc64b47f046c1ff4ddfcdc9334a.tar.gz
Small refactoring
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 207bc5337840..03df240cf498 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fastfetch-git
pkgdesc = Like neofetch, but much faster because written in c
- pkgver = r610.2310162
+ pkgver = r640.4895c68
pkgrel = 1
url = https://github.com/LinusDierheimer/fastfetch
arch = x86_64
@@ -33,12 +33,8 @@ pkgbase = fastfetch-git
optdepends = dbus: Media player and song output
optdepends = xfconf: XFWM theme + xfce-terminal font
provides = fastfetch
- provides = fastfetch-garuda
- provides = flashfetch
conflicts = fastfetch
- conflicts = fastfetch-garuda
- conflicts = flashfetch
- source = git+https://github.com/LinusDierheimer/fastfetch.git
+ source = fastfetch-git-r640.4895c68::git+https://github.com/LinusDierheimer/fastfetch.git
sha256sums = SKIP
pkgname = fastfetch-git
diff --git a/.gitignore b/.gitignore
index e31985feb44f..19fa468e2728 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
-fastfetch/
+fastfetch*
src/
pkg/
-*.pkg.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 328fdf98a8ed..025fc79455b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Linus Dierheimer <Linus@Dierheimer.de>
pkgname=fastfetch-git
-pkgver=r610.2310162
+pkgver=r640.4895c68
pkgrel=1
pkgdesc="Like neofetch, but much faster because written in c"
arch=("x86_64" "i686" "pentium4" "armv5" "armv6h" "armv7h" "aarch64")
url="https://github.com/LinusDierheimer/fastfetch"
license=("MIT")
+
depends=()
makedepends=(
"git"
@@ -35,29 +36,29 @@ optdepends=(
"xfconf: XFWM theme + xfce-terminal font"
# "rpm-tools: rpm package count"
)
+
_provides_and_conflicts=(
"fastfetch"
- "fastfetch-garuda"
- "flashfetch"
)
provides=("${_provides_and_conflicts[@]}")
conflicts=("${_provides_and_conflicts[@]}")
-source=("git+https://github.com/LinusDierheimer/fastfetch.git")
+
+_src_dir="${pkgname}-${pkgver}"
+source=("${_src_dir}::git+https://github.com/LinusDierheimer/fastfetch.git")
sha256sums=("SKIP")
pkgver() {
- cd "fastfetch/"
+ cd "${_src_dir}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build()
-{
- cd "${srcdir}/fastfetch"
- cmake .
- cmake --build . --target fastfetch # don't build flashfetch, as it is meant to be configured at compile time. So it doesn't make sense to pre build it.
+_build_dir="build"
+
+build() {
+ cmake -B "${_build_dir}" -S "${_src_dir}" -Wno-dev
+ cmake --build "${_build_dir}" --target fastfetch # don't build flashfetch, as it is meant to be configured at compile time. So it doesn't make sense to pre build it.
}
package() {
- cd "${srcdir}/fastfetch"
- cmake --install . --prefix "${pkgdir}/usr"
+ cmake --install "${_build_dir}" --prefix "${pkgdir}/usr"
}