summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Zhang2021-02-15 11:09:05 +0800
committerBruce Zhang2021-02-15 11:09:05 +0800
commit16c5ed2bb645170bb9aa76df39e38fcf891c0a9e (patch)
tree7ffb8f1f30a36b3ff6d870bd6fb0988b7ecb7eaa
downloadaur-16c5ed2bb645170bb9aa76df39e38fcf891c0a9e.tar.gz
Initial upload: fastocr-git 0.1.1.r0.2e32336-1
newpkg: fastocr-git
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b13a47dfce9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fastocr-git
+ pkgdesc = FastOCR is a desktop application for OCR API.
+ pkgver = 0.1.1.r0.2e32336
+ pkgrel = 1
+ url = https://github.com/BruceZhang1993/FastOCR
+ arch = any
+ license = LGPL3
+ makedepends = git
+ makedepends = python-setuptools
+ provides = fastocr
+ source = fastocr::git+https://github.com/BruceZhang1993/FastOCR
+ sha256sums = SKIP
+
+pkgname = fastocr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bad15cbec20d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/fastocr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..462d5e995326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bruce Zhang <zttt183525594 [at] gmail [dot] com>
+pkgname=fastocr-git
+pkgver=0.1.1.r0.2e32336
+pkgrel=1
+pkgdesc='FastOCR is a desktop application for OCR API.'
+arch=('any')
+url='https://github.com/BruceZhang1993/FastOCR'
+license=('LGPL3')
+depends=()
+makedepends=('git' 'python-setuptools') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=('fastocr')
+source=('fastocr::git+https://github.com/BruceZhang1993/FastOCR')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/fastocr"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/fastocr"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/fastocr"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 data/FastOCR.desktop "$pkgdir/usr/share/applications/FastOCR.desktop"
+}