summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaytars2020-11-29 10:56:01 +0800
committerBaytars2020-11-29 10:56:01 +0800
commit1e91cd9c9d20d3c9bea2220e83ab7996818c5a9c (patch)
treecc4e5a7771d19a5e42a7878ae1ea975fa578068b
downloadaur-1e91cd9c9d20d3c9bea2220e83ab7996818c5a9c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9cb772450b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fastp
+ pkgdesc = a tool designed to provide fast all-in-one preprocessing for FastQ files, developed in C++ with multithreading supported to afford high performance
+ pkgver = r337.424900e
+ pkgrel = 1
+ url = https://github.com/OpenGene/fastp
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = make
+ depends = zlib
+ provides = fastp
+ conflicts = fastp
+ source = fastp::git+https://github.com/OpenGene/fastp.git
+ sha512sums = SKIP
+
+pkgname = fastp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..549d474d79cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Baytars <feicuihuangfeng@qq.com>
+# Maintainer: Baytars <feicuihuangfeng@qq.com>
+pkgname=fastp
+pkgver=r337.424900e
+pkgrel=1
+pkgdesc="a tool designed to provide fast all-in-one preprocessing for FastQ files, developed in C++ with multithreading supported to afford high performance"
+url="https://github.com/OpenGene/fastp"
+license=('MIT')
+arch=('any')
+depends=('zlib')
+makedepends=('git' 'make')
+provides=(${pkgname})
+conflicts=(${pkgname})
+source=("${pkgname}::git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ make
+}
+package() {
+ cd "${srcdir}/${pkgname}"
+ install ${pkgname} ${pkgdir}/usr/local/bin/${pkgname}
+}