summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Pina Martins2017-01-18 10:51:46 +0000
committerFrancisco Pina Martins2017-01-18 10:51:46 +0000
commit90db1e31f01dadf39019db1ac1aff7a22990d0bb (patch)
treed14145b8799f846ca785731e928ab70baf4fdde3
downloadaur-90db1e31f01dadf39019db1ac1aff7a22990d0bb.tar.gz
Initial commit for fastqt.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5df24890d4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fastqt
+ pkgdesc = FastQC port to Qt5: A quality control tool for high throughput sequence data.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/labsquare/fastQt
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-charts
+ depends = karchive
+ depends = hicolor-icon-theme
+ source = https://github.com/labsquare/fastQt/archive/0.1.tar.gz
+ sha256sums = b698aec72dd27735303408b1a0ba8a22e18bf1eef3c699e1494e44d0c478e0aa
+
+pkgname = fastqt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca4ea788daa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stunts <f.pinamartins@gmail.com>
+
+pkgname=fastqt
+pkgver=0.1
+pkgrel=1
+pkgdesc="FastQC port to Qt5: A quality control tool for high throughput sequence data."
+arch=('i686' 'x86_64')
+license=('GPL3')
+url="https://github.com/labsquare/fastQt"
+depends=('qt5-charts' 'karchive' 'hicolor-icon-theme')
+source=(https://github.com/labsquare/fastQt/archive/${pkgver}.tar.gz)
+sha256sums=('b698aec72dd27735303408b1a0ba8a22e18bf1eef3c699e1494e44d0c478e0aa')
+
+prepare() {
+ cd "${srcdir}/fastQt-${pkgver}"
+ echo ${pkgdir}
+ sed -i "s|target.path.*|target.path = ${pkgdir}/usr/bin|g" FastQt.pro
+ sed -i "s|desktop.path.*|desktop.path = ${pkgdir}/usr/share/applications|g" FastQt.pro
+ sed -i "s|icons.path.*|icons.path = ${pkgdir}/usr/share/icons/hicolor/48x48/apps|g" FastQt.pro
+
+}
+
+build() {
+ cd "${srcdir}/fastQt-${pkgver}"
+ qmake
+}
+
+package() {
+ cd "${srcdir}/fastQt-${pkgver}"
+ make install
+}