summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-08-22 10:46:18 +0200
committerLucas Werkmeister2019-08-22 10:46:18 +0200
commitbca48c2a0499a35e65deade7ee4d6a38278b4d63 (patch)
treea58315e21f71ce178de30126a9a029bfb8d8c618
parentc373534698894484af4c383b2d86d1029f2e02ea (diff)
downloadaur-bca48c2a0499a35e65deade7ee4d6a38278b4d63.tar.gz
Update to 19.2.0
The top-level license files turned from symlinks into proper files (oracle/fastr#90 [1]), so now we have to copy those as well. [1]: https://github.com/oracle/fastr/issues/90
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d4444de8211..ef1f761a90d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jul 17 21:52:53 UTC 2019
pkgbase = fastr-bin
pkgdesc = Graal based, high-performance implementation of the R language
- pkgver = 19.1.1
+ pkgver = 19.2.0
pkgrel = 1
url = https://github.com/oracle/fastr
arch = x86_64
@@ -10,8 +8,8 @@ pkgbase = fastr-bin
depends = graal
provides = fastr
conflicts = fastr
- source = https://github.com/oracle/fastr/releases/download/vm-19.1.1/r-installable-linux-amd64-19.1.1.jar
- sha256sums = 4e38d2d99677fa34b55f6007f36dfcb06fa0e48558e7264a752713c732f87854
+ source = https://github.com/oracle/fastr/releases/download/vm-19.2.0/r-installable-linux-amd64-19.2.0.jar
+ sha256sums = cb3aef553a6bfe8347743739fbb579f9ffb231520d74b55c0e82761a4934824d
pkgname = fastr-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3e330ca3063f..6f219d130753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname_=fastr
pkgname=${pkgname_}-bin
-pkgver_=19.1.1
+pkgver_=19.2.0
pkgver=${pkgver_/-/_}
pkgrel=1
pkgdesc='Graal based, high-performance implementation of the R language'
@@ -15,13 +15,13 @@ optdepends=()
provides=("$pkgname_")
conflicts=("$pkgname_")
source=("https://github.com/oracle/$pkgname_/releases/download/vm-${pkgver_}/r-installable-linux-amd64-${pkgver_}.jar")
-sha256sums=('4e38d2d99677fa34b55f6007f36dfcb06fa0e48558e7264a752713c732f87854')
+sha256sums=('cb3aef553a6bfe8347743739fbb579f9ffb231520d74b55c0e82761a4934824d')
package() {
local file eq permissions mode name target
mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/
+ cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_FASTR 3rd_party_licenses_fastr.txt
printf '\n' >> META-INF/permissions
while read -r file eq permissions; do
@@ -54,5 +54,5 @@ package() {
ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
done < META-INF/symlinks
- install -DTm644 jre/languages/R/LICENSE_FASTR "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -DTm644 LICENSE_FASTR "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}