summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2020-04-23 23:23:45 +0200
committerLucas Werkmeister2020-04-23 23:23:45 +0200
commit6ce73e15831fde85998ea267f8b27b88cef6df07 (patch)
tree11d25de6b8f5549be560dad232a7437ad560a48c
parent15973f15c647dd3e6b694b670332309fe954b9c8 (diff)
downloadaur-6ce73e15831fde85998ea267f8b27b88cef6df07.tar.gz
Update to 20.0.1
The symlinks file now lists some extra libraries (making the “manual” symlink of libgfortran in package(), now removed, fail), and they’re all part of gcc-libs, so I’m assuming that FastR now includes *all* of its own libraries and tentatively removing the gcc-libs dependency. (Unfortunately, on my system, gcc-libs is required by a bunch of other packages, so I can’t easily test if FastR works without it installed.)
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb340c47075d..afda476004f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = fastr-jdk11-bin
pkgdesc = GraalVM-based, high-performance implementation of the R language (Java 11 version)
- pkgver = 20.0.0
+ pkgver = 20.0.1
pkgrel = 1
url = https://github.com/oracle/fastr
arch = x86_64
license = GPL3
depends = jdk11-graalvm-bin
- depends = gcc-libs
- source = https://github.com/oracle/fastr/releases/download/vm-20.0.0/r-installable-java11-linux-amd64-20.0.0.jar
- sha256sums = da934a4bee62738cc11d978c5849fb60f330bd403f3aa4843dab1acbfc5fd3d6
+ source = https://github.com/oracle/fastr/releases/download/vm-20.0.1/r-installable-java11-linux-amd64-20.0.1.jar
+ sha256sums = 2ac19c269da9adc038721fc145250d1fb055663d69818b6f7503b5a9f3f50380
pkgname = fastr-jdk11-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7985d146c26a..22ab40cf7071 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,15 @@
java_=11
pkgname_=fastr
pkgname="${pkgname_}-jdk${java_}-bin"
-pkgver=20.0.0
+pkgver=20.0.1
pkgrel=1
pkgdesc="GraalVM-based, high-performance implementation of the R language (Java ${java_} version)"
arch=('x86_64')
url='https://github.com/oracle/fastr'
license=('GPL3')
-depends=("jdk${java_}-graalvm-bin"
- 'gcc-libs') # for libgomp.so.1 and others
+depends=("jdk${java_}-graalvm-bin")
source=("https://github.com/oracle/$pkgname_/releases/download/vm-${pkgver}/r-installable-java${java_}-linux-amd64-${pkgver}.jar")
-sha256sums=('da934a4bee62738cc11d978c5849fb60f330bd403f3aa4843dab1acbfc5fd3d6')
+sha256sums=('2ac19c269da9adc038721fc145250d1fb055663d69818b6f7503b5a9f3f50380')
package() {
local file eq permissions mode name target
@@ -52,7 +51,5 @@ package() {
ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-${java_}-graalvm/$name"
done < META-INF/symlinks
- ln -s -- '/usr/lib/gcc/x86_64-pc-linux-gnu/6.5.0/libgfortran.so.3' "$pkgdir/usr/lib/jvm/java-${java_}-graalvm/languages/R/lib/libgfortran.so.3"
-
install -DTm644 LICENSE_FASTR "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}