summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortty20992019-06-23 13:44:24 +0800
committertty20992019-06-23 13:44:24 +0800
commit3feaca22aa0901c3c9a3a683f227550538d86163 (patch)
tree4443e26cbceeecf22817eec0217c39c9bf258a2a
downloadaur-3feaca22aa0901c3c9a3a683f227550538d86163.tar.gz
fastrtps-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8007df0b83e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fastrtps-git
+ pkgdesc = eprosima Fast RTPS is a C++ implementation of the RTPS (Real Time Publish Subscribe) protocol
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://www.eprosima.com
+ arch = any
+ license = Apache2.0
+ makedepends = cmake
+ makedepends = jdk8-openjdk
+ makedepends = gradle
+ conflicts = fastrtps
+ source = git+https://github.com/eProsima/Fast-RTPS
+ sha256sums = SKIP
+
+pkgname = fastrtps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc24eb24710d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tong Chunli (tty2099@gmail.com)
+
+pkgname=fastrtps-git
+_pkgnm=Fast-RTPS
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="eprosima Fast RTPS is a C++ implementation of the RTPS (Real Time Publish Subscribe) protocol"
+arch=('any')
+url="https://www.eprosima.com"
+license=('Apache2.0')
+depends=()
+conflicts=(fastrtps)
+makedepends=(cmake jdk8-openjdk gradle)
+source=(git+https://github.com/eProsima/Fast-RTPS)
+sha256sums=('SKIP')
+
+
+package(){
+ cd "$srcdir"
+ rm -rf build
+ mkdir build && cd build
+ export GRADLE_USER_HOME=/tmp
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DTHIRDPARTY=ON -DBUILD_JAVA=ON -DCOMPILE_EXAMPLES=OFF -DPERFORMANCE_TESTS=ON -DSECURITY=ON ../$_pkgnm
+ make
+ make DESTDIR=$pkgdir install
+}
+