summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:06:05 -0600
committernot_anonymous2015-07-05 18:06:05 -0600
commitbd09d98b43d8b1eaa18543f61176e36fb8b78a96 (patch)
tree150d5d030efea6917d74e4edb54d5092ce119b10
downloadaur-bd09d98b43d8b1eaa18543f61176e36fb8b78a96.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--diff.commport.cpp6
-rw-r--r--diff.main.cpp4
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3bc2fcfd552
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = fasttuna
+ pkgdesc = Ham Radio - Elecraft K2 CLI-based Rig Control
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.qsl.net/ab6cv/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gcc-libs
+ source = http://www.qsl.net/ab6cv/fasttuna.tgz
+ source = diff.commport.cpp
+ source = diff.main.cpp
+ md5sums = e54d204076016c8f3bfac8fca36ad460
+ md5sums = 70857407071f9dcf87c3c82c93a7fe53
+ md5sums = aa9a9e9e50ea35ac04b11b38a7738299
+ sha256sums = 657546c5fd0f625dd38b6220353a1ec8cdd4113370ed6104c2386516a381ee84
+ sha256sums = e3ab6ff9aee0ad7ba4acf93baaf3857249d0cfe06cbc05a1d252b537d7296646
+ sha256sums = f8e96c05b1eaada77fc58e3d4af91777a9f45cd2c9ec8b1e91fc426b0cb41dce
+
+pkgname = fasttuna
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2d961552cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Original Submitter: Bob Finch <w9ya@arrl.net>
+
+pkgname=fasttuna
+pkgver=1.0
+pkgrel=1
+pkgdesc="Ham Radio - Elecraft K2 CLI-based Rig Control"
+arch=('i686' 'x86_64')
+url="http://www.qsl.net/ab6cv/"
+license=('GPL')
+depends=('gcc-libs')
+source=(http://www.qsl.net/ab6cv/$pkgname.tgz
+ diff.commport.cpp
+ diff.main.cpp)
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ patch -p0 < ../diff.commport.cpp
+ patch -p0 < ../diff.main.cpp
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make prefix=$pkgdir/usr install
+ mv $pkgdir/usr/bin/kookoo $pkgdir/usr/bin/fasttuna
+
+ mkdir -p $pkgdir/usr/share/fasttuna/docs
+ cp -a kookoo/docs/en/*.??ml $pkgdir/usr/share/fasttuna/docs
+}
+md5sums=('e54d204076016c8f3bfac8fca36ad460'
+ '70857407071f9dcf87c3c82c93a7fe53'
+ 'aa9a9e9e50ea35ac04b11b38a7738299')
+sha256sums=('657546c5fd0f625dd38b6220353a1ec8cdd4113370ed6104c2386516a381ee84'
+ 'e3ab6ff9aee0ad7ba4acf93baaf3857249d0cfe06cbc05a1d252b537d7296646'
+ 'f8e96c05b1eaada77fc58e3d4af91777a9f45cd2c9ec8b1e91fc426b0cb41dce')
diff --git a/diff.commport.cpp b/diff.commport.cpp
new file mode 100644
index 000000000000..7ab7cf11950f
--- /dev/null
+++ b/diff.commport.cpp
@@ -0,0 +1,6 @@
+--- kookoo/commport.cpp 2003-09-17 10:52:48.000000000 -0600
++++ kookoo/commport.cpp 2015-02-01 11:21:07.128704160 -0700
+@@ -9 +9,2 @@
+-#include <string>
++#include <cstring>
++#include <cstdlib>
diff --git a/diff.main.cpp b/diff.main.cpp
new file mode 100644
index 000000000000..4832f66f15c0
--- /dev/null
+++ b/diff.main.cpp
@@ -0,0 +1,4 @@
+--- kookoo/main.cpp 2003-09-19 23:40:33.000000000 -0600
++++ kookoo/main.cpp 2015-02-01 11:22:46.238825188 -0700
+@@ -25,0 +26 @@
++#include <cstdlib>