summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbemxio2024-03-26 16:33:12 +0100
committerbemxio2024-03-26 16:33:12 +0100
commit34019f5aa8f9debb540474bf8b1b65a2bc84d63e (patch)
tree7212e5c3befc82c61048fa3dcdc3fdad7091edce
parent175b718b93be87d1483099a498258d3f6ea09b69 (diff)
downloadaur-34019f5aa8f9debb540474bf8b1b65a2bc84d63e.tar.gz
change the symlink name
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ddf7c61feee..54589a9d1bf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fastvideods-encoder-git
pkgdesc = Encoder for the FastVideoDS format
pkgver = r2.1a25c4f
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/Gericom/FastVideoDSEncoder
arch = i686
@@ -11,7 +11,7 @@ pkgbase = fastvideods-encoder-git
makedepends = dotnet-sdk
depends = dotnet-runtime-6.0
depends = ffmpeg5.1
- provides = FastVideoDSEncoder
+ provides = fastvideods-encoder
source = git+https://github.com/Gericom/FastVideoDSEncoder.git
source = fix-library-path.patch
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 38940e216b3d..b9af70d141ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=fastvideods-encoder-git
pkgdesc="Encoder for the FastVideoDS format"
pkgver=r2.1a25c4f
-pkgrel=2
+pkgrel=3
epoch=1 # required because of the changed version numbering scheme
arch=(i686 x86_64)
@@ -15,14 +15,14 @@ license=("LicenseRef-unknown")
depends=(dotnet-runtime-6.0 ffmpeg5.1)
makedepends=(git dotnet-sdk)
-provides=(FastVideoDSEncoder)
+provides=(fastvideods-encoder)
source=("git+https://github.com/Gericom/FastVideoDSEncoder.git" "fix-library-path.patch")
md5sums=("SKIP" "594a84df360613bbd562f4b77c743850")
pkgver() {
# move to the source directory
- cd "${srcdir}/FastVideoDSEncoder"
+ cd FastVideoDSEncoder
# use the number of revisions since beginning of the history
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
@@ -30,7 +30,7 @@ pkgver() {
prepare() {
# move to the source directory
- cd "${srcdir}/FastVideoDSEncoder"
+ cd FastVideoDSEncoder
# apply the patch
patch --forward --strip 1 --input ../fix-library-path.patch
@@ -56,5 +56,5 @@ package() {
install -Dm755 Build/* "${pkgdir}/usr/share/fastvideods-encoder/"
# make a symlink to the executable
- ln -s /usr/share/fastvideods-encoder/FastVideoDSEncoder "${pkgdir}/usr/bin/FastVideoDSEncoder"
+ ln -s /usr/share/fastvideods-encoder/FastVideoDSEncoder "${pkgdir}/usr/bin/fastvideods-encoder"
}