summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoirscape2018-12-21 18:16:20 +0100
committernoirscape2018-12-21 18:16:20 +0100
commit3fee6fc851dabebbcf549e3b5045c07b7a8761d5 (patch)
treed06a4a4c806a2b6f39c341760d502afc97c7d67f
parentb122166f86a6fb8281ed6015004e6606558aa620 (diff)
downloadaur-3fee6fc851dabebbcf549e3b5045c07b7a8761d5.tar.gz
Make proper git package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac5b8e0544a..ae37aa631750 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = fatattr-git
pkgdesc = Small linux application to see or modify MSDOS attributes in a FAT file system
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Terseus/fatattr
- arch = x86_64
- arch = i686
+ arch = any
license = GPL
makedepends = git
makedepends = scons
makedepends = clang
provides = fatattr
conflicts = fatattr
- source = git+https://github.com/Terseus/fatattr.git
+ source = fatattr-git::git+https://github.com/Terseus/fatattr.git#branch=master
md5sums = SKIP
pkgname = fatattr-git
diff --git a/PKGBUILD b/PKGBUILD
index f966b8d07fbc..7efac8be6de2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: noirscape <neko at catgirlsin dot space>
-pkgname=fatattr-git
-_pkgname=fatattr
+# Maintainer: noirscape <deepnavy at waifu dot club>
+pkgname=fatattr-git # '-bzr', '-git', '-hg' or '-svn'
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Small linux application to see or modify MSDOS attributes in a FAT file system"
-arch=('x86_64' 'i686')
+arch=("any")
url="https://github.com/Terseus/fatattr"
license=('GPL')
depends=()
-makedepends=('git' 'scons' 'clang')
-provides=('fatattr')
-conflicts=('fatattr')
-options=()
-source=(git+https://github.com/Terseus/fatattr.git)
+makedepends=('git' 'scons' 'clang') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("fatattr")
+conflicts=("fatattr")
+source=("$pkgname"::'git+https://github.com/Terseus/fatattr.git#branch=master')
md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
- cd "$srcdir"/"$_pkgname"
+ cd "$srcdir/${pkgname%-VCS}"
scons
}
package() {
- cd "$srcdir"/"$_pkgname"
+ cd "$srcdir/${pkgname%-VCS}"
mkdir -p "$pkgdir"/usr/bin
- install -Dm755 "bin/$_pkgname" "$pkgdir"/usr/bin
-}
+ install -Dm755 "bin/fatattr" "$pkgdir"/usr/bin
+} \ No newline at end of file